DENT - Destructible Environment Network Toolkit

If you go to content/Dent/Character/Bp_Dent_Character and check the “event graph”

you will see the Event BeginPlay as in atatched in the picture , in the LoadUi Comment this is where the widget is called from, any problems just give me a shout

I just bought this and it said that this is a 4.18 supported content pack, but it’s broken as can be.

57 fatal errors.

It’s not because the apex plugin is disabled by default either.
By adding it to a project and then enabling apex destruction, or enabling and adding it to a project. It’s broken either way.

It doesn’t seem to be a mistake that this is mislabeled as 4.18 supported, b/c of the note about apex destruction in the description on the store.

So what gives? Am I doing something wrong?

hi. Saxon Rah

Thanks for buying DENT and you are correct that it is 4.18.

having a look at the errors it does look like the errors that you see when that apex plugin is not enabled.

If the files are added before the plugin and if they are saved they break.

Let’s find out what’s hapaning and get you all fixed up

Which version of 4.18 are you using Are you using source or store build of UE4

Can you as a test.
​​​​​​1 fresh game - third person template.
2 open game and activate the apex plugin
3 save all and exit
4 add dent

And we can see if the error is there, if this is still showing as an issue.
And then we can look at the next step.

That’s exactly my problem, If i add it to a new blank project with apex destruction enabled or disabled, it breaks either way.
4.18.2 Binary version (non source)
Perhaps my download was corrupted or something? What I will try and do is delete 4.18.2 and all marketplace content and retry it from the beginning.
I’ll come back here in a few mins to update this post.

Yep, deleting the engine and dent local content seems to have fixed the problem. Thanks for your help Purple_Dolphin!

When I get back I will install 4.18.2 and check. I have tested on 4.18.1 and 4.18.0 as on the subversion there is never a need to update the packages.

and this is the first report of this. I am very interested to find out what has happened / happening

Can you zip up the wonky test package and send me a link to [EMAIL=“”]


Phew that was worrying me there.

Thank you very much for your patience in this issue and the time you took in looking in to it’s resolution

Hope you enjoy DENT and have fun blowing stuff up. :slight_smile:


Your current FAQ link directs to a virus spyware alert webpage. Might want to check into that.

Just had a look from my phone. Its not giving me an error I will check as soon as I get access to a pc. Thanks for the heads up.

The joys of shared web hosting

The website is ok.
i have checked and it seemed that there are some disingenuous sites using the same IP on the shared hosting package. I will place a support ticket with the provider.

DENT does not work with 4.19?

It does work it was tested. Please advise what the issue you are experiencing is.
have you added the apex plugin to the engine

I loaded into a fps temp. I get a compiler error on BP_DENT_MASTER, BP_DENT_MASTER_KILL_SWITCH.

What error are you seeing. Is it breaking the compile ?

Yes. It is breaking the compile.

Can you send me the errors you are getting please

I have performed all of my upgrade tests again today incase i over looked somthing and there has been no issues

Part of this process is as below,
I have tested the cook build and package processes in 3 stages,
1 - Blank Third person - No issue
2 - Blank third person with apex plugin - No issue
3 - Blank third person with apex plugin and DENT - No issues

Suggestions for resolution to your problem
1 - Please check the you have the correct visual studio version
2 - That the APEX plugin is enabled before DENT is installed to the project,
3 - Please post the log files so they may be inspected, as this issue is not the result of an incompatibility with DENT and 4.19, the functionality work as expected. it may be to do with the integration to your project. but with out the log files neither I or the community can look in to your issue.

Thanks, I forgot about Apex.

Good stuff

How do I remove DENT from a project? I tried deleting everything from the project, but we still get the DENT popup.

Sorry to hear you are removing DENT did it not perform as required? :frowning:

Are you meeting the loading block the black box that says DENT instead of saying unreal editor or the HUD overlay
( The loading box was only ever for me that should not be added to a project from the store if that is what the issue is I will need to discuss with epic on getting it removed)
If It is the HUD overlay then that is set on the main characters construction script.