Default pawn judders on floor with simulate physics and gravity on

I changed the default pawn (and the default gamemode in order to use the new default pawn) by creating a new BP with the parent as DefaultPawn and called it BP_DefaultPawn. I then edited the BP and enabled Simulate Physics and Enable Gravity on the CollisionComponent.

Then I hit Play in the editor (after compiling BP_DefaultPawn) and I get micro-bouncing on the floor on the Z axis. If I eject from the pawn and look at it in the details pane I can see that it’s bouncing very quickly by 1~ unit.


Steps to reproduce: Create a new basic code project and do the above in the latest version (I’m using 4.16.2).

How can I stop this so that it just sits there?

There is no animation to pause, it’s just a basic sphere mesh component attached to a basic sphere collision component.

Solved it myself (was a new thing that came in 4.16.2 - i.e. 2 days ago):

In 4.16 we enabled PCM
for PhysX (their new contact
generation algorithm). While this
gives great performance improvements,
we are still working with them to fix
some final stability and jitter
issues. As such we recommend turning
PCM off if you experience jitter in
your simulation. (Project Settings >
Physics > Simulation > Enable PCM)

Turned it off and it fixed it.