Download

Dedicated server issues.

EDIT: looks like this is my 100th post :slight_smile:
Hi! I wasn’t sure where to put this, but I ended up placing it here.
So, I have been trying to get a dedicated server running for… about 5 hours now, with very little success. Unreal front end is reporting “error: server target not found”. <projectname>Server.Target.cs is located in <projectname>/source, and does appear in visual studio. I have been following this tutorial (A new, community-hosted Unreal Engine Wiki - Announcements and Releases - Unreal Engine Forums), being stuck at phase 6.

Things that could be meaningful:

Unreal front end is NOT detecting any maps, even though <projectname>/content has 2 .umap files.

I am NOT sure which instances of “Game” I should have replaced with my project name. I have been trying different combos, with no results.

I sort of skipped phases 1-3, for 3 reasons:
Building the engine takes insanely long, especially when you really don’t know what you are doing. I once tried doing it for 22h+, with no results, which discourages me from doing it if not absolutely necessary.
I think there was some mention in some patch note that building the engine from source is no longer required(?).
During my last try, I had already ran things like unreal version selector, so I had some hope it will be enough.

I have mainly been working on blueprints, as every time I have picked up C++, it has kicked me in the butt. Hard. So, don’t expect me to understand all that much :stuck_out_tongue:

Hmm. I haven’t needed any of that faff so far.

A .bat file containing the following did everything I needed -


"c:\Program Files\Epic Games\4.7\Engine\Binaries\Win64\UE4Editor" "c:\users\Stuart\Documents\Unreal Projects\MyProject\MyProject.uproject" /Game/Folder/structure/to/maps/MinimapTest -server -log

Game seems to map to the content folder, so if you have /content/maps/examplemap that would be /game/maps/examplemap

then launch a client and type open 127.0.0.1

or another batch file with


"c:\Program Files\Epic Games\4.7\Engine\Binaries\Win64\UE4Editor" "c:\users\Stuart\Documents\Unreal Projects\MyProject\MyProject.uproject" 127.0.0.1

All of that was gleamed from here -

Obviously replace all paths and project names for your paths.

This gets you up and running with a test server. Its probably not the right way if you want a fully hosted server, but for just firing up and testing your network code with you and some colleages it works quite nicely.

I am getting the following crash when executing “open 127.0.0.1”

MachineId:B5377EEA4067BC19954CB08347A29DFF
EpicAccountId:d480ae9dd3614a17982e8a6c932bec17

Unknown exception - code 00000001 (first/second chance not available)

Assertion failed: 0 [File:d:\buildfarm\buildmachine_++depot+ue4-releases+4.7\engine\source\runtime\sockets\private\bsdsockets\SocketSubsystemBSDPrivate.h] [Line: 94]

KERNELBASE + 109229 bytes
UE4Editor_Core!FOutputDeviceWindowsError::Serialize() + 292 bytes [d:\buildfarm\buildmachine_++depot+ue4-releases+4.7\engine\source\runtime\core\private\windows\windowsplatformoutputdevices.cpp:95]
UE4Editor_Core!FOutputDevice::Logf__VA() + 248 bytes [d:\buildfarm\buildmachine_++depot+ue4-releases+4.7\engine\source\runtime\core\private\misc\outputdevice.cpp:144]
UE4Editor_Core!FDebug::AssertFailed() + 1079 bytes [d:\buildfarm\buildmachine_++depot+ue4-releases+4.7\engine\source\runtime\core\private\misc\outputdevice.cpp:224]
UE4Editor_Sockets!FSocketSubsystemBSDCommon::TranslateGAIErrorCode() + 248 bytes [d:\buildfarm\buildmachine_++depot+ue4-releases+4.7\engine\source\runtime\sockets\private\bsdsockets\socketsubsystembsdprivate.h:99]
UE4Editor_Sockets!FSocketSubsystemBSD::GetHostByName() + 208 bytes [d:\buildfarm\buildmachine_++depot+ue4-releases+4.7\engine\source\runtime\sockets\private\bsdsockets\socketsubsystembsd.cpp:69]
UE4Editor_Sockets!FResolveInfoAsync::DoWork() + 439 bytes [d:\buildfarm\buildmachine_++depot+ue4-releases+4.7\engine\source\runtime\sockets\private\ipaddress.cpp:47]
UE4Editor_Sockets!FAsyncTask<FResolveInfoAsync::FResolveInfoAsyncWorker>::DoThreadedWork() + 18 bytes [d:\buildfarm\buildmachine_++depot+ue4-releases+4.7\engine\source\runtime\core\public\async\asyncwork.h:317]
UE4Editor_Core!FQueuedThread::Run() + 123 bytes [d:\buildfarm\buildmachine_++depot+ue4-releases+4.7\engine\source\runtime\core\private\hal hreadingbase.cpp:326]
UE4Editor_Core!FRunnableThreadWin::Run() + 102 bytes [d:\buildfarm\buildmachine_++depot+ue4-releases+4.7\engine\source\runtime\core\private\windows\windowsrunnablethread.cpp:73]
UE4Editor_Core!FRunnableThreadWin::GuardedRun() + 93 bytes [d:\buildfarm\buildmachine_++depot+ue4-releases+4.7\engine\source\runtime\core\private\windows\windowsrunnablethread.cpp:26]
kernel32 + 88525 bytes
ntdll + 178321 bytes

What am I doing wrong?

im not sure what you did for now. so here is a quick list of the importent steps

  1. you need a engine build from source…
  2. add the serverbuild.cs to your project
  3. regenerate your visual studio files (importent)
  4. open visual studio and build your project with Development Server and Development Editor
  5. now you can pack the project with the ProjectLaucher (be sure to cook the content)

This might help - http://www.youtube.com/watch?v=zSA8zUo8oCg

Okay, the crash is fixed. I had accidentally types in “open 127.0.01” , which obviously is invalid.
Also, thanks to IanBreeg, the dedicated server is now running :smiley:

Now, I have an issue with the server running in “menuMap”, when where it really should be is “demoMap” (my map for the actual gameplay). based on the log, the map server seems to be running is “Entry”, which is less than helpful. How do I fix this?

Have you looked in project settings -> maps and modes?

game default map is “menuMap” & editor startup map is “demoMap”. Can’t find any other map selection bars…

If you click the expand arrow just under ‘editor startup map’ there show also be ‘server default map’, ‘transition map’ and ‘local map options’.

Thanks you so much! I found it, created a “lobby” map where I put in all the (limited) logic involved with choosing a map, set it as the server startup map, and sure enough, I saw the “Welcome to demomap! Your gamemode is DemoGamemode_C_0” in the console, and when connecting to the server, I was able to jump around, and, when I connected another client, the two would see each other jumping around :smiley: After a month of less-than-productive efforts, I finally got here. Once again, thank you, and I hope this thread will help others facing the same situation in the future :slight_smile:

No problem.

It’s something I re-found the other day and made a mental note not to forget about =]