Download

Dedicated Server Crashes

I’m making a post here because we’re not getting very far on unreal answers.

Our game builds and packages without issue. The client also launches without issue, but the dedicated server version of the game always crashes and gives us the same error every time:

[2016.12.10-23.24.46:035] 0]LogWindows:Error: Fatal error: [File:E:\Unreal Engine - Git\Engine\Source\Runtime\Engine\Private\PhysicsEngine\PhysXLibs.cpp] [Line: 102]
[2016.12.10-23.24.46:035] 0]LogWindows:Error: Failed to load module ‘…/…/…/Engine/Binaries/ThirdParty/PhysX/Win64/VS2015/PxFoundationPROFILE_x64.dll’.

  • We’ve built and compiled the game server on two different computers, using 4.14.1 an 4.14.2.
  • I’ve also replicated the issue with a blank third person project.
  • I’ve tried renaming the PxFoundation_x64.dll in the packaged engine folder to PxFoundationPROFILE_x64.dll.

Same problem.

This problem started with 4.14 and does not seem to exist in 4.13. Something must have changed with these dll files.

Our full logs (Across two different games):
https://answers.unrealengine.com/questions/535343/running-a-server-failed-to-load-module-pxfoundatio.html

Can anyone help us figure out why this is happening?

Your packaged game is missing the shipping files found in: <package_dir>\Engine\Binaries\ThirdParty\PhysX\Win64\VS<your_version>\

As a workaround copy the missing non-profile and non-checked dlls from <engine_dir>\Engine\Binaries\ThirdParty\PhysX\Win64\VS<your_version>\

What are you using to package your game? And are you manually executing UAT and/or manually adding the test/shipping executables to the packaged game? This would be a cause of -package “missing” dependencies like this.

I run into the same issue, and has sucessfully resolved it by updating VS2015 update2 to update3 and reinstalling vc_redist.x64.exe.