Dedicated server crashes on startup, Package contains editor only data

I have tried building a dedicated server for my game however the server crashes on startup. I tried again using the third person template game but it still crashes with the same error. I followed the following guide: link, when building the project but I am using the latest release branch version from github which is 4.22.1 as the project was created on version 4.21 then converted to 4.22.

The server executable builds successfully but crashes during startup. I have tried again with the third person template but the crash logs give the same error.

crash logs

I will try soon to build the dedicated server for a project on 4.18, as this is the last version that the tutorial recomends, but this will take time as compiling the engine from source seems to be about a 4 hour process for me and the project I’m trying to build the server for was created on version 4.20.

Any suggestions would be appreciated, I’m kind of at a loss as for how to fix this as I’ve even tried to remove all animations from the third person game and it still didn’t work.

I fixed it, I didn’t move the server executable to the windowsNoEditor/“projectname”/binaries/win64 folder. After moving the server executable to this folder the server ran correctly without crashing.

Thanks! This solved the same error for me.
I followed the same tutorial and ran into the same error on UE4.22.2. I burned a few hours compiling in different configurations while troubleshooting it.D: