Download

Dedicated Server Can't Find GameMode

I re-organized my project structure which moved a few things around. I deleted the parent “TopDownBP” folder and moved all the blueprints to Content->Blueprints (instead of Content->TopdownBP->Blueprints).

Now I’m getting this error in my dedicated server:


[2016.07.10-11.50.07:078]  0]LogLinker:Warning: Can't find file '/Game/TopDownBP/Blueprints/TopDownGameMode'
[2016.07.10-11.50.07:078]  0]LogUObjectGlobals:Warning: Failed to load '/Game/TopDownBP/Blueprints/TopDownGameMode': Can't find file '/Game/TopDownBP/Blueprints/TopDownGameMode'
[2016.07.10-11.50.07:079]  0]LogLinker:Warning: Can't find file '/Game/TopDownBP/Blueprints/TopDownGameMode'
[2016.07.10-11.50.07:079]  0]LogUObjectGlobals:Warning: Failed to load '/Game/TopDownBP/Blueprints/TopDownGameMode': Can't find file '/Game/TopDownBP/Blueprints/TopDownGameMode'
[2016.07.10-11.50.07:079]  0]LogUObjectGlobals:Warning: Failed to find object 'Class /Game/TopDownBP/Blueprints/TopDownGameMode.TopDownGameMode_C'

Here is what I wanted my structure to look like. The GameMode was moved to the Blueprints folder:
58bde29e92658a19b946e55f626234ef6b98d2d5.png

Just to try and apply a quick fix to the problem, I tried re-creating the TopDownBP and Blueprints folder and moving the GameMode back there. I then saved in UE4 editor, deleted the Server files from binaries folder and re-exported the dedicated server. Still getting this error :(. I even tried creating a duplicate GameMode and setting it as the new GameMode. No luck. The server still wants the original one.

Here I tried to re-create the original structure so my GameMode is where the server says it can’t find it:
08d4839d691cd53670bc8b0aadd84946d231909b.png

Is it really bad that i deleted the TopDownBP folder and re-organized things? I’ve tried to “Fix up Redirectors” in all my folders but no dice. I also regenerated the visual studio files by right clicking on the project. Is there some sort of “refresh” option that I’m missing to tell UE4 to recognize the changes I’ve made?

Important to add: I’m having no problem with PIE. Dedicated server with a couple clients works just fine in PIE.

This issue is giving a black screen to clients that try and connect to the standalone dedicated server. I’m assuming this is because a blank Game Mode is being substituted when the server can’t find the one it’s looking for.

I figured out what the issue was. When I changed the default server game mode I didn’t re-export the client for Windows x64. Apparently the dedicated server gets the project settings from the packaged Windows 64 client. I thought re-exporting the server would be good enough.