Download

Decal blending issues

Hi guys

I am currently having some issues with the blending of some decals.

The material editor to the right shows how it should look like, but in the scene, I only get a very faint outline of parts of the texture (check out the bsp brush with the decal applied to it). I have no idea why this is showing up so faint.

Note: If I hook the texture up to the emissive channel, it does show up, but I don’t want it to be emissive…What am I missing here?

http://www.team-imx.com/images/UE4/decal_blending_issues.jpg

Cheers,
michael

I think I found the reason, although I’m not sure how this should work correctly.

The decals only seem to be visible correctly if they are hite by direct light (i.e. I put a point light in front of it). Indirect / baked lighting does not seem to work (The DBuffer options don’t work either, I’ve tried that).

So how do I set up the scene (a night scene in my case) so that the decals show up correctly even when only hit by indirect/bounce light?

This is a limitation caused by the static lighting being done in the geometry pass before the decals are applied. There are two options, turn off static lighting or enable the decal buffer (see this question: https://answers.unrealengine.com/questions/25508/decals-not-rendered-without-direct-lighting.html).

@Parkar: Thanks a lot, got it working.

I was irritated as the DBuffer blend modes were listedin the decal mat, but just not working -wasn’t aware of the required BaseEngine.ini tweaks. In case anyone else has this problem as well, here are the setting:

BaseEngine.ini under [SystemSettings]
r.EarlyZPassMovable=1
r.EarlyZPass=2
r.DBuffer=1

Cheers,
Michael