DDS Files

Hey All,

I was seeing that people are trying to import .dds files and getting the “failed to import” message. While a standard format, Unreal Engine does all the conversion and compression in the editor. That said, one type of .dds file is supported: the cubemap. You can find more infomation on the supported cubemap .dds file here:



So, that means that I have to convert all my diff, spec & other maps from dds to tga to import them to UE4?

Heya Vertal,

If you don’t have access to the uncompressed source images, then yes. If you have a large number of files, the free ATI Compressonator tool has a solid and simple batch conversion to any of its supported file formats, including TGA.

Thanks a lot for response! But for batch covert i use IrfanView viewer.

DDS shows up in the filetypes selection now, but trying one still gives unknown format.
If it’s not possible to import compressed DDS, why not have the engine decompress it, but make note of the compression type used (1 bit alpha, 8 bit alpha, no alpha,if BC3 for normal maps, that kind of stuff)

Why would you want to import heavily compressed images, (as in DDS) - that would be like using j-peg. People are often confused when they extract out content from some engines, (no names mentioned) because they’re DDS, but would have almost definitely been imported as png or targa. DDS is an awful compression format, and UE4 doesn’t need it or any support for it.

Hey there,
i followed the hints and tutorials here for Cubemaps and always get an import failed. I tried several DXT settings but none ist working.

Any suggestions of how to fix that or how to get around that Nvidia ****?
I am currently trying to use the CubeMapGen by AMD, but with not much luck.

NVM. The Nvidia export it’s working now. Don’t know why.

Hey guys,

I know this is quite late to the party, but I threw this together which can probably help with your problems:

Cheers, Brett

Hi there,
the post is a bit old maybe. But I found it trying to find a solution for the DDS importing issue on UE Mac Editor, and I was able to find a solution by myself and wanted to share it in case someone else reach this post.
I generated a DDS cube map image with the SpaceScape software, but when trying to import it into UE, it was always returning the message “Failed to import”, and since the NVIDIA Tools are only available for Windows, I started looking for an alternative without too much luck, until I remembered that I have installed a copy of GIMP and decided to give it a try, and oila! I was able to open the DDS file, then export it again, I selected RGBA8 as the Format and deselected the option “Generate mipmaps”, and then imported it into UE again and it worked!

Hopes this helps to someone else.


Hey ADCamEl, can you let me know how you installed the DDS plugin for Gimp on OSX? I’m unsuccessful in compiling this guy with all it’s dependencies. Can’t seem to find dev versions for osx of gtk+, Glib and Gimp which apparently is needed

Basically it seems like you need to compile gimp + it’s dependencies from source. Is that what you’ve done? Cheers.

OK after about 4-5 hours of digging deeper into the dependency hole of trying to compile Gimp from source (ending up compiling the most obscure low level libs one can think of) I eventually found this Gimp version:, 2.8.14, that includes DDS support (facepalm). I got it to work by doing this

  1. Spacescape: Export SkyBox as DDS with “Export for: Source”
  2. Open in GIMP for OS X 2.8.14
  3. Export as DDS: Compression=none, Format=RGBA8, Save=as cube map

Now UE4 can import the .dds file and generate a .uasset from it.

What I’ve tried that doesn’t work is: ImageMagick cli, XnConvert and Photoshop+DDSPlugin(Mac).

Error: DDS file contains data in an unsupported format.
Error: Texture import failed

…is what I get every time with these methods. (My guess is they don’t support the RGBA8 format, 'cause I haven’t seen that option among these tools)

Thank you so much!

SpaceScape exported to Unreal seems to work fine in Win10 now. The edges don’t align though.

The “failed to import” issue that I had was the result of this workflow:

  1. Panorama-to-Cubemap: Panorama to Cubemap
  2. Convert Cubemaps to DDS: Convert cube map images to DDS format in the GIMP - YouTube

In this case, exporting the file with Javoire’s settings worked.


Bump. DDS no longer works in 4.19 for some reason.

Creating Cubemap or a Skybox in UE4 with 4.19 is easy. Be resourceful and follow these steps.

  • Coverop… Absolutely incorrect and this would be covered in documentation if this was accurate.
  • 4.19 does support .DDS and you can easily create Cubemaps.
  • If you’re having an issue importing them then you are using accurate process of exporting the .DDS.

Follow the instructions here:

Ensure you download the following tools:
Unreal Documentation:

  1. Watch This:…
  2. Watch This:


Has anyone been able to do this recently? I’m trying to get a skybox from Spacescape into Unreal 4.21 and I’m getting that same “DDS uses an unsupported format” error. Tried everything in this thread, and it just doesn’t seem to recognize my DDS

Found a solution. Open the file in Photoshop. Under Image->Mode, set it to 32bit. Then do File->Save As, and choose Radiance as the file type and save it as a .HDR file. Then import that HDR file into Unreal, and it’ll be recognized as a Cubemap.

For people using the free PAINT.Net 4.2.5, it is also possible, save it as .dds and choose B8G8R8A8 (Linear, A8R8G8B8)

1 Like

m00508.rar (1.3 MB)
For research purposes i tryed to import compressed dds texture to unreal, i wasn’t allowed to, but opening compressed texture in photoshop having installed dds nvidia plugin for it, i save as dds but as uncompressed, and then unreal imports dds texture without any problem, but yeah, the size is 4 MB while compressed is less than 700 KB for x1024 res texture.