Datasmith on sub-levels all disappeared. Autosave is not good fix.

Hi all,

Again, apologies in advance if this has been covered already; I’m a architecture grad, not a UE4 pro.

Short version: I had a project with multiple sub-levels all working relatively fine, using the Unreal Studio ‘Multi User Viewer’ as a template project.
A number of separate Datasmith files (on allocated sub-levels) all disappeared and had to restore manually with all the Autosaved UMAP files.


  1. All my Datasmith material is now gone, I can’t see any of it in the editor.
  2. I can only see the DatasmithSceneActors and associated StaticMeshActors in the World Outliner only.
    2a. Right clicking on a ‘lost’ StaticMeshActor doesn’t give the ‘Browse to Asset’ option even though all the UASSET files are intact and still in their folders
  3. The heirarchy is all broken for the DatasmithSceneActors
  4. One DatasmithSceneActor does have heirarchy intact but can’t see any of the stuff in the editor (so same problem)
  5. Even lighting, reflections captures etc (all created in UE4) on a specific sub-level are gone and only visible in World Outliner

Q: Why and how could this have happened, I don’t want the clunky Autosave method to be my only resort.

a) All material on the Persistent Level is fine and 100% intact.
b) I was playing around with level streaming, changing each sub-level between ‘Always Loaded’ and ‘Blueprint’ trying (and failing) to make one of the sub-levels stream in
c) I’m using the Unreal Studio and selected the ‘Multi User Viewer’ template level. However I made my own ‘Master’ blank level and sub-levels and have them all in a separate ‘Maps’ folder in Content Browser, so that shouldn’t affect anything as it’s ‘separate’.

I went into File Explorer > [projectname] > Saved > Autosaves > Game > Levels and found an earlier UMAP file and copied them into the sub-level folders back in Contents folder, deleted the old UMAP and renamed the pasted in autosave UMAP file as the original file name.
This seems SO CLUNKY and am wondering how Epic can make Autosaves / backup better.
And while i’m on it, what’s the difference between Backup and Autosave? Backup folder contains UASSET files; are these useful when content is lost?

I hope the solution is simple.

Thanks in advance,

Hey man,

Ran in to this issue today. I think I might have a fix, as I was able to close UE4 and reopen with everything intact. Not sure if you are still plagued with this issue, but this was my fix, at least until it happens again. I know i caused the issue with making a copy of my project and naming it something else, then attempting to upgrade the original to a newer version of UE4.

So I went in to Project Settings -> Maps & Modes -> Default maps, and changed the Editor startup Map to something random, then back to the umap file I wanted to use and saved. Seemed to have worked for me, I’m guessing it just bugged out. All of my references are still ok now.

Let me know if this worked for you as well, and for anyone else having this issue.