Download

custom character forward movement shakes - any ideas?

Hi

I’m probably missing some basic setting, but I can’t figure out why my custom FPS character’s forward movement shakes. I’ve cross-checked with the template FPS controller, but I just don’t see it.

It’s basically shaking up and down very little when I move around. My guess is it’s something physics related.

Anyone? :slight_smile:

Thanks.

It could be that it probably collides with something → disable the collision of the arms/weapons,… :slight_smile: (just the capsule should have a collision)

Ok, maybe I should be more specific :slight_smile:

I’m building my own fps controller, from scratch, and that’s the one shaking. I already tried the template one and removing the arms. No shaking on the template controller.

My own only has the capsule component and camera. All movement inputs are coming through fine, it’s just the shaking issue I’m struggling with.

I’m building it for learning purposes :slight_smile:

It’s really difficult to say what could be wrong → We need more information e.g how you have made everything, a video that shows your problem,… :slight_smile:

I followed TeslaDev’s guide here: https://www.youtube.com/watch?v=VMD-z2Xni8U

It’s more or less the same as the template.

My problem is, whenever I move around; forward, back, left and right, the camera shakes vertically very slightly. I’m using the Rift, and it’s very apparent in VR. It seems as if the floor/ground is bobbing up and down frantically, but only slightly (if that makes any sense).

The template controller is smooth when walking around.

*edit: Maybe it’s not the character, but a world collision thing. It seems as if the character moved through the floor alittle, then gets “levelled” again with the ground.

Hmm, it seems the problem just went away on it’s own.

Initially, I had a BSP for the ground, and then a plane mesh. Problem was on both. I just removed the ground, and put in another BSP, problem went away. Tried my plane again, still no problem.

what…?

Hmm, really strange…when you have the plane + BSP in your level on top of each other it could might have caused some collision problems… but otherwise it doesn’t make any sense :stuck_out_tongue: (but when the problem reappears, go to the build tab and rebuild the geometry)