Download

CreateDefaultComponent(CDO) not working after packaging

Project works fine in editor or in windows, but something happens after packaging and it won’t load assets at all!
What i did before:
> I deleted most of starter content to make game smaller in RAM. It worked. But my game on smartphone is render 5-6 frames on start, then crashes.
> I thought that this is not enough, so i deleted more assets, levels, but didn’t touched some assets i used already. Now on android it crashes with message that it can’t load files because it is not found them.
Even engine files not loading!
What have i done?..

Log:
Log.txt (48 KB)

Screenshot:
bfdd4a6e49a479baec5195c6496a60ace48541af.png

Hi HungryDoodles,

It looks like you’ve deleted some stuff from your project and the project is still trying to locate those assets/files/modules. Have you tried returning to a backup from before the deletion? It looks like engine.ini files have been deleted, and many of the deleted assets are still associated with your project.

For after that, if you’re still having a problem, I dug around in your log and noticed that one of the missing modules is ‘OnlineSubsystemGooglePlay’. I found an AnswerHub post with that similar problem that may help.

If none of that works, can you repost this issue along with your complete failed build output logs and the monitor logs to an AnswerHub post? That would be the most help. Thanks very much!

Thanks for answer. I think i really need to report it as a bug, bacause packaged project works on PC, but on Android it doesn’t.
I don’t sure what i deleted from starter content so the package still have size over 600 MB (!) but with few assets (for Android it’s huge). Seems like whole .pak is corrupted somehow… i’am newbie… it is supposed to happen one way or another.
Folder StarterContent is still appears in project after restart, but i had deleted it several times.
Now i’am migrating some assets into blank project…
Luckely i have only 2 meshes, 1 particle system and 1 class (Pawn_), so migrating these files to blank project will be easy.

Done. I compiled it, launched on my device, it firstly crashed, i relauched it, it opened and only i see is two thumbsticks what i can control with hard lags (approx 10 fps) and blank blackscreen… Back to the begining…
My device is Fly iq452 with PowerVR SGX 544MP GPU. Interesting moment is that it shown me first frame! THEN black screen.

And another moment in building on Android is package name (com.[company].[project]). I’d tried to find out why build is failed due to invalid arguments for 2-3 days. Find it. I wrote “com.Re-Law.Encryptor” where is the ‘-’ symbol was illegal, but i forget about it (i knew it actualy) and engine hadn’t noticed me about that. Little tip: only characters that allowed in package name is latin alphabet in lower and upper cases (‘a’-‘z’ and ‘A’-‘Z’).

When you say the packaged project works on PC but not Android, can you explain this a little further? Like, you’ve packaged it for Windows and that works, but when you package it as an apk it doesn’t work? Or do you perhaps mean it works in the editor when you select Mobile Preview?

Well, if i will launch my game as standalone on PC or in editor (even with mobile preview) it works fine, but if i do same on Android it will show me message full of CDO errors (screenshot in first post) then just quit. Before i deleted something important project worked on Android. It launches, renders 4-5 frames then black screen (no render, but GUI) or crash. Then i cleaned up content by only deleting starter content, compiled, tried to launch and BOOM… This message appears. And files that i deleted using the editor are still in content folder (in explorer), they are not gone. The size of .apk didn’t changed: it was 630 MB, it still 630 MB. I don’t sure what there supposed to be, but in /Encryptor/Saved/Config folder all .ini files are empty (on device). All .uasset-s is there (on device), all look same as it was before, but CDO is not working.
I can send you whole project or/and apk (6,5 GB and 600 MB non-compressed), maybe using yandex-disk or google-disk or something similar, as you want :slight_smile:
About new balck project:
Maybe i compiling not as i need to? (NDK - latest, SDK - android-19, Minimum api level - 14, possibly too much different numbers :slight_smile: )
I’ve tried to launch Sun Temple, it crashed…
What is interesting - my project in new clean editor environment is launched on my device, but with black screen (need to test on other devices). I saw log and this was very very strange log full of NaNs and !IsValid(), what maybe causes black screen and 7-10 fps (i can contol thumbsticks).
There it is: MyProjectLog.txt (229 KB)

Can you also attach the log for the crash of Sun Temple? Logcat logs would be nice too if you can get them.

Well, i didn’t found them. I’ve fumbled many places (even where i can get only with root permissions), but none found. But i installed it incorrectly, i had not enough free storage space, then
Trying to reinstall… I’ll take time…
Tappy Chicken is works very well by the way…
Launched. Loading… Black screen…
O_o OMG! It works! 3-5 fps, but it works!
With Temporal AA, basic reflections (cubemaps and speculars), in full HDR, on 720p, with only 1 GB RAM…
I’am surely forget something in my project. Maybe i should try to build project without my C++ code. Building… Nope. It’s now crashes. But the log is looks interesting: the file is not finished writing! After “LogRHI:GL_MAX_TEXTURE_SIZE: 4096” there is a string “[2015.03.23-07.54.44:7” and EOF.
That how it looks: EncryptorBlankLog.txt (8 KB)
Lauched game several times - all the same.
Found something interesting in android logs (right after crash, line 4088):
D/UE4 ( 5479): Fatal error: [File:D:\BuildFarm\buildmachine_++depot+UE4-Releases+4.7\Engine\Source\Runtime\Engine\Private\Materials\MaterialShared.cpp] [Line: 1290]
D/UE4 ( 5479): Failed to find shader map for default material WorldGridMaterial! Please make sure cooking was successful.
No shader map for WorldGridMaterial? What? My project works at least somehow on 4.7.2, not it crashes on 4.7.3… I REALLY have both left hands.
Log: AndroidLog.txt (455 KB)
Oops, these are different logs (i mean error the same but time is different).
Checked game log and android log (pulled using adb) after same launch and spotted, that the time is the same!
Well, that didn’t changed something…
And as always Windows package works fine. Turning off the static lightning isn’t helping (solution for the same problem on windows).

Hi HungryDoodles,

I’m not really sure where your issue stands at this point, so you might consider just going ahead and opening up an AnswerHub threadto raise visibility for this. I’m not 100% sure it’s a bug, so you make the call as to whether or not to include this as a Bug Report or just a straight up Android tagged question for the community. Here is the’how to report a bug’](How do I report a bug? - UE4 AnswerHub)thread with detailed instructions, and you can see down at the bottom there are locations for various logs you will want to include.

Thanks!

I don’t know what i should report actually, there are many problems and i don’t know their consequences. Only i know it’s not a bug(s), your engine works perfectly (that’s why i like it), just i have no experience with it (2 weeks), so it is OK that i have these kind of problems.
If shortly:
►CDO possibly caused by my mindless holocaust of assets (starter content) ignoring all warnings about references, what caused corruption of the .pak file (or similar). Size of package didn’t changed after “nukage”, so something like that really happened.
►When i migrated to other project i launched it on my phone, but lags was insane and there was only thumbsticks seen, background is black. First 2-5 frames were rendered, then only GUI, no 3D. Logs says that there was many NaNs. Likely it was my C++ code.
►And the last error i can’t understand. It’s just happened, i didn’t changed anything but switching project taget hardware to desktop and back to mobile.
►And NONE of these happening on PC (Windows).
Well, i decided to make my game on Wndows/Mac/Linux, if shortly - for Steam publish.
Had 2-3 years of experience on Unity even with network, but i don’t like C#: it works slow and as-it-wants (about automatic refences). And there i thought: if know C++ and don’t want to write on C#, why don’t use UE4? Funny, that i was ready to pay $19/month for subsription and you are suddenly made it free :smiley: