Correct lightmap index but still overlapping uvs?

Every time I build lighting it says that there are overlapping uvs by 42% no matter what I change. I tried making my own second uv channel and also tried letting ue4 generate the lightmaps for me but both ended up saying there were overlapping uvs. Everything was working fine until today and I have no idea why.

Here is my lightmap sets on the second channel:

Here are my settings:

Btw my lightmap resolution is set at 1024

It looks like it’s using UV channel 0 even though I set the destination index at 1. I’ve been stumped for the last couple hours and can’t figure out what is going on.