Control Nvidia Flex asset movement by player


First of all, I’m new in Unreal and maybe I’m asking dumb question, but I can’t find any answer on the internet.

So, I have sphere mesh ( ball ), which I want to be main character in the game ( like rolling ball game ). I want this ball to be soft body, so it can deflate or interact with other objects as in reality.

I’m using nvidia flex physics for soft body implementation ( I’ve defined sphere object as flex soft body asset ) and it works perfect, but the problem is that because of unreal’s simulated physics can’t be enabled on flex assets I couldn’t add any torque or other forces to this object, so it won’t move by player.

The solution I tried: I’ve created another ball, but smaller which isn’t flex asset and placed it inside flex ball, created blueprint for it so it can be moved with controller ( keyboard, mouse), enabled attach to rigids on flex options for flex ball and it works, but I think it isn’t good workaround, because flex ball always imitating inside ball’s physics and it doesn’t look well.

Do you have any suggestions?

And also sorry for my English.

dont know much about flex but maybe there is a way to disable the collision between the flex ball and the physics one.
as for forces, you can try adding rotation/movement in a direction with a function over time in order to fake real torque

1 Like