Download

Content Sensitive issues, the best node reference? & a Mac blueprint window issue.

5 quick questions/queries that have got me stumped and a little confused after a day with the engine (I’ve been watching all the great Ue4 tutorials for the past week and finally started tinkering hands on)

Content Sensitive Issues

  1. Why do some actions not get shown when you tick ‘Content Sensitive’ when making a new node even though they can be connected to. (I seem to constantly be turning the switch on or off. Sometimes getting more options with content Sensitive ‘on’ which seems odd?..). Is it buggy or am I simply misunderstanding its use.

Mac Windows Issue
2. I’m using a Mac running the latest Yosemite OS. On all the great UE4 tuts online they always position Blueprint over the main editor and are able to click or drag a mesh/material etc to reference in blueprint. When I try that it moves my blue print window behind the main editor and the editor window to the fore. Is there a way to stop this happening… Also it won’t let me dock the BluePrint window into the interface (I can undock and dock other windows) and is getting very frustrating.

UE4 Answer Hub won’t let me post?
3. I tried writing a question out on UE4 AnswerHub . I was logged in, I’d chosen a category… added 5 or less tags but the ‘post question’ button did nothing. I was using Safari on a Mac… tried 3 separate times :frowning: and it doesn’t tell me why?

Zoom issue
4. Oh and zooming in and out of the Blueprint graph using the scroll wheel keeps stopping and won’t let me zoom in, unless I first zoom out a bit more first… anyone else getting this?

Best BluePrint node reference?
5. Coming from Unity using C# where they had the ever helpful albeit daunting scripting reference, is their a simple goto page where I can type in any action for BluePrint and get an explanation of what it is, what it does, what it expects and a simple example? (Is the BluePrint API reference the goto place? the search seems a bit to wide as it checks the AnswerHub and wiki as well?)

Thanks for any light you can shed… Sorry for being such a complete newb. I’ve watched over 4 hours of tutorials before I jumped into the software but some things that I thought made sense err… haven’t. Happy to learn and enjoying the journey… just hit a bit of a rocky road early on. :slight_smile:

Hi there, welcome to the forums! :slight_smile:

In version 4.5 there are a couple of issues being reported to do with this, they are in the process of switching over to a new menu system and it looks like there are some parts not working quite right. I have seen that these issues have been acknowledged on AnswerHub and should be fixed in the upcoming release.

The Blueprint API reference you noted is the best place to find info on BP nodes, it contains info on almost every single node available in blueprints, and is still being improved at this time. From the main documentation page you can search for any of the nodes, and on the search page you are able to set an option to only search the documentation, or to search all sites at once (forums, answerhub, and docs). So if you are getting a lot of pages in your search, be sure to sort it by documentation only.

This one I am not sure on as I use a PC, but could you please ask this on AnswerHub so we can get it fixed for you? Speaking of AnswerHub:

Could you try this again, and if it still doesn’t work are you able to download another web browser to see if it will work? I have not heard of any issues to do with Safari, but trying from another browser should help.

With the zoom you need to make sure you have the graph canvas selected before it will let you zoom, so if you are working in another window the graph doesn’t have focus. If this is happening when the graph does have focus, I have not seen any reports of this yet but this is also be something to put on AnswerHub so epic can take a look at it.

No worries! Let me know if you are still having problems with AnswerHub from another browser, I can get someone to look into it for you. Thanks! :slight_smile:

Thanks for the great reply.

I’ll have a go with Firefox and the Answerhub a little later.

The zoom issue is an odd one… I can zoom out consistently with each little roll of my middle mouse wheel… but when I scroll forward it’s not recognised unless I scroll particularly fast… :-? I would say it’s down to the mouse but I can scroll a webpage or 3DS Max just fine…

I’ll send the questions to AnswerHub when it works.

Thanks again … and thanks for the ‘welcome to the forum’.

Jon

Hi Jon,

We are currently experiencing some issues with the AnswerHub that should be resolved very soon. So normally you should be able to use Safari to access the AnswerHub and not have to switch browsers. Sorry for the inconvenience.

Just a quick update, the issue on AnswerHub has now been resolved, let us know if you have any further issues with it. Thanks Jon!