Completely black shadows drive me crazy.

I apologize for the confusion, I’m probably very tired trying to figure it out. I have a fairly simple (I hope) problem: the opposite side of the direct lightning source is completely black.

    • I use dynamic lighting for an open-world RPG with a change of time of day
    • Raytracing is too expensive for FPS, I can’t use it
    • Version 4.24

This is what it looks like from the side of the light source:

this is what it looks like from the back:

How do I make objects slightly brighter from the other side?

I did solve a problem with a hammer, but I want to know** is there a smarter way**? My solutions was:

  1. I created a second source direct lightning which moves in the opposite direction from the original SUN light source, not creating shadows and having a minimum value of brightness (shadows doesn’t look very good + eats up a few fps)

The best, but for some reason buggy way:

  1. At the SkyLight within daytime I set a Light Color white with intensity 0,5 and change it to 0 when the night comes (so far the closest I option). If i keep light color as it is - at night half of scene looks weird:

I think you could add a SkyLight. If static, build the lighting. If dynamic, it will automatically illuminate darker zones.

PS: for night, you will also need the skylight.

As i said - skylight is already there :slight_smile:

Add a second directional light, set its Index to 1 (1st directional is in 0), and intensity to below 1 (not 0 though). Transition it in as a moonlight (or if there’s no moon then hide the sun actor it is connected to), and adjust Atmosphere settings to adapt to the low lighting if needed.

Check if under the landscape is a mesh, if under the landscape too close is a mesh, it can cause these kind of shadow.

Example / Fix

I know, but maybe with a very low intensity or not Movable.

Usually, this should be solveable with the Skylight, maybe turn off the Skylights casting shadow.

You have an alert saying the Texture Streaming Pool is over ~21,000 MB budget. I think it means it doesn’t have ~21,000 MB it needs to render everything.

Check also if you by mistake copied the landscape.