Compiling time being over 1 minute

I’m new to the unreal engine, and i don’t really know if it’s normal but every time that i compile my Project it takes around 1m30s to compile just a new PrintLine to my terminal game, i dont know how to provide more information but if someone that has more experience than me could help i would be glad.
I have a FX 6300, 8GB ram and 1060, i know it’s a weird setup but i don’t think that it would actually mess up my compilation time, thanks for the attention, and sorry if this is the wrong forum to post about troubleshooting.

That sounds about right for your spec hardware.

Only 1 minute 30 seconds? Must be nice. :frowning:

the compiler likes to warm up…

it takes like 2/3 mins for the first compile, and about 13-14 seconds for the second.

this is most times, sometimes some unknown factors to me ( newbie here ) can cause some variances in compile time.

God Bless you. May Jesus Christ be Charitable unto you.

Acts 10 : 33 - 48, google it, its Awesome.

Thanks for the replies, it took some time to accept my post since was the first one sorry i didn’t notice it was here already.
I guess this is normal then, I am just not used to it, after the first compile i though it should be faster cause it was going to be working only on what i changed but i guess that was a wrong, basically i just need a better setup if i want a faster compile time, thanks y’all

I would suggest “wating” on getting a new setup :

because epic is going to release a new engine update next year, unreal 5.0, which will change the system requirements :

if you wait for a stable build of the “new” engine, it will save a lot of money in theory? because if you upgrade now, you run the risk of not metting the “new” requirements, but if you wait for after its released, you will have “zero” risk involved.

One thing that you can do relatively cheaply - buy more RAM. 8GB is quite small even for simple PC usage today. Upgrading RAM gave me a huge boost and I think it compiles somewhere between 15-60 seconds now. UE4 and projects are on SSD.

These build times are still too long and interruptive, I hope someone will optimize them further

Something to try and I’m having success with. Tweak the options in your file so each .cpp file is compiled separately and use precompiled header.