Download

[Community Project] WIP Weather & Ocean Water Shader

Ditto … upgrade to 4.13

Evening all. Using this in UE version 4.12.5 and I seem to have an odd bug.

I’m using this with a tiled world with “World Origin Rebasing” and I seem to get a rather large square of water that is completely flat. It just doesn’t appear to be affected by displacement.
a1858ef1e0ea7813fe738aa874a02d5f9ba61529.jpeg

As I move around the world, this flat area moves with me, due to the origin rebasing.

I’m not entirely sure. But could it be something to do with having no reference to a landscape? I don’t know how I would use a reference to a landscape as my world is made up of lots of landscape actors.

Any ideas whats going on? Cheers all! And keep up the great work!

Thank you for your Awesome ocean Project, just an ASK i have an BIG Ocean for my RPG Game…, Well the Only Problem is Planar Reflection takes a HUGE PErformance hit, even when you dont see the Ocean, Its Like i have an BIG Ocean with a Lots of Island… I get - 10-12 FPS even when you dont see The Ocean… so it renders even when it doesnt Should…

and thats a really Big performance Problem, can anyone Help me?

Checkout treat as Background, and use as Occulder (checked out both) didnt Worked.

The project is several megabytes in size???
Great, Thanks a lot Guys

WIP Weather & Ocean Water Shader project is several megabytes in size???

I think we have to wait for a plugin update as 4.13 has improvements with planar reflection:

New: Planar Reflection Improvements

Added "Render Scene Two Sided" to planar reflections, which can be useful to limit leaking.

Added "Show Only Actors" and “Hidden Actors” to Scene Capture Component for easy use without having to call BP functions.

Added "Show Preview Plane" to Planar Reflection actors

The view state is recreated on planar reflection edit, which resets the Temporal AA history, allowing instant previewing of changes

Just a quick note. I noticed that the moon texture has mipmaps disabled. Making it look very grainy.

Setting the Mip Gen Setting back to “FromTextureGroup” makes it look a lot better.

I’m still having a few issues getting this to look right on my tiled world.

Sun seems to cut out too soon.
And I still get this large flat square in the ocean as I mentioned previously.
Underwater post process doesn’t seem to function for me either.

My landscape is using a total range of 2048 meters. With the water level starting at 512meters from the bottom. This makes the water plane sit at -51100 (+100 units due to where UE imports landscapes on Z). I’ve moved the swim volume to match, that works fine. And when I come out of the water I get the effect on screen. But when I’m under water I get no fog or distortion effects.

That is really odd, I have this on a huge MMO world and I am using the best options for the shader and didn’t really have to tweak it at all. Its barely a difference of 1 FPS with or without it. I know this because I was having issues with FPS in game and systematically removed everything to isolate it. This ocean barely affects my performance at all. You might find that either its not set up right in your project or that it is an entirely different culprit. For instance, I resampled my map to a lower resolution (without changing size) and I went from 15fps looking across the map without occlusion blocking berms and buildings and such to a solid 60FPS with full editor quality, material quality, full shader quality on the ocean and tesselation on a huge desert that covers half the map for goodly footprints and sand disturbances.

If your ocean is setup right, I would keep tweaking and removing one thing and re-adding it until you isolate the culprit, but if you had a 4k map like I did or a large one in general, your culprit is probably your landscape. Don’t forget to take advantage of LODs and culling. I have zero level streaming and my big **** map is running like a champ… now.

I was actually crazily surprised at how little resources this ocean uses. I used to have nothing but a pretty plane that was very limited in size and it impacted my resources far worse than this infinite system.

This is just an amazing project. Its not just pretty. Its really well done with resources in mind.

… and I also cannot wait to get my hands on the 4.13 plugin… :smiley:

Thanks for this. It’s simply amazing.

The project comes with license information… "including without limitation the rights
to use, copy, modify, merge, publish, distribute, sublicense, and/or sell
copies of the Software, and to permit persons to whom the Software is
furnished to do so, subject to the following conditions:

-Free for use in any UE4 project-
Anyone is free to copy, modify, publish, use, or compile this software,
either in source code form or as a compiled binary, for use in any
Unreal Engine 4 game, simulation, arch-viz, or other related UE4 projects,
both commercial or non-commercial."

I think you are in the clear for commercial.

Domm, if you just used migration from the ocean project over to your project, you might want to check your plugins folder in your project and make sure the relevant version of the oceans plugin, which is separate in its own right really, is in there. That should clear up all your problems. If you know this and its not the issue, I apologize. But ya never know.

Sorry not trying to spam messages, just saw a few simple questions easily answered…

hey The Rift Keeper ,Thanks for answering,

it seems there was a compiling problem,
i just compiled my project (after updating Windows SDK, and reinstalling the 2015 Common Tools ) and and now the plugin packaging works ( if it helps, this could be a solution to “the plugin cannot be found” problem).

Hi guys, finally tested the plugin, and must say it is simply awesome!

Made a video
https://youtube.com/watch?v=g2SsguPbWEw

wow that looks awesome!

Yes… yes… it really is dope… Nice work

Tks, it´s amazing !

It is more than just good looking and well scripted. Its a very creative use.

Really love this water!
But for the weather it seems incomplete - is this still being continued i wonder?

when it will be available the version 4.13 ?

I don’t know. Last update was 3 month ago