Download

Collision glitch on automatically generated collisions

Hi,

I am importing a large amount of elements and using the automatic collision generation on import. As you can see, on the straight parts of the pipe, the collision are on the outside of the mesh but on the curved parts, the collision is on the inside. This causes issues when the character approaches the mesh as they get stuck inside or teleported on top of (just generally glitches the game). I am trying to keep everything automated as there is a lot of these curved meshes in the scene. Is there a setting that would make the mesh “2 sided” like the material is currently?
Capture.PNG
Capture2.PNG

Any help is greatly appreciated. I think it has something to do with the fact that the material is 2 sided (otherwise it makes the pipe hollow on the bends).

Thanks,
A