Download

Collision capsule prevents from attaching to component

Hi! As the title says I had problem with attaching my weapon actor which is constructed from collision mesh as a main parent and under it I have skeletal mesh as a weapon, to my character with socket on his back. After an hour I figured out that collisions prevents from attaching to it and since it’s pickable item (using line trace) I can’t have it withouth that collision. So my question is if it’s a bug that needs to be reported or is there some way to remove/override that collision before attaching it and vice versa?

Have you tried disabling physics and collision on the item before attaching it?

No, but not bad idea, thanks I will try it when i get home

Nope… still not working. It simply doesn’t like collision component and not just collision itself. I’ve managed little fu** you collision component and while attaching i choose as target “SK_FPGUN” and not root that works fine but that is unpractical when I have around 40+ items that have same problem and something with get children doesn’t seems to work.

EDIT: Ok… it’s a little bit different. Attach to component doesn’t work when “simulate physics” is enabled on any kind of component. So only thing I need is to find component that has collision enabled and untick it. Any way to make it dynamic? Like find child of root that has physics enabled and disable it? Or at least find child with name and disable physics?