Clipping Plane

How to set the Far Clip Pane? There is only Near Clip Plane in Project Settings. My problem is that i have lots of planes in the scene using opacity textures. When i go close to objects, clipping works fine, but everything is blown up when looking further. It doesnt even matter how close or far the planes are from each other, the background seems to come front. Or is it because i stretched a plane throughout the whole scene, makes clipping problematic?

Ok, so i accidentaly found that this was about sorting translucency. I was knifing project settings and set Translucency Sort Policy to Sort Along Axis, not Sort By Distance, and so far it works. After all it wasnt about clipping, although it looked like it would have something to do with it.