Child components moved away


I watched “Blueprint QuickShot - 6 - making Procedural Content” and created the same ManyBoxes blueprint. Then I decided to give some physics to boxes and created a blueprint called PhysicsBox, that contains a static mesh component with enabled gravity. In ManyBoxes, I changed Add StaticMeshComponent to Add Child Blueprint, and set PhysicsBox in its parameters. But when I tried to simulate this, all boxes moved to the other point, but the root component of ManyBoxes didn’t moved. But if to use just PhysicsBox, then it works perfectly



I created another project and migrated ManyBoxes and PhysicsBox in it to test them, but they still don’t work…

What it can be caused by

With best regards,


P. S. Does the EULA allows me to upload ManyBoxes.uasset and PhysicsBox.uasset? If yes, then how?

Added the *gif file, that illustrates the problem:

I found the problem!

I tried to use wall sconce instead of PhysicsBox, and everything worked perfectly.

I checked the differences: PhysicsBox had only 1 component - static mesh, and wall sconce had 2 components (actually there is also a point light, but it doesn’t matter) - scene component and static mesh component.



When I added scene component to my PhysicsBox, the problem was solved.
Thanks to everyone for your help!

P. S. Why the scene component was so important?