Child actor component still bugged

I’ve got weird bug with ‘Add Child Actor Component’ node. I’m making runner game and i’ve got few blueprints with different road parts, where i want to spawn obstacle objects. In few of them Add Child Actor Component works, but there are few, where after restarting the engine values of that node resets and doesn’t work anymore untill i set it again.

This is how it should look:

This bug has two options, in both Child Actor Class are still set but:

  1. Default changes to “None”

  1. Every options dissapear like the class is set to None

I found a lot of topics about child actor component but this one looks different. Is there any way to fix it or a way around it? I’ve tried to make new Blueprints of my roads but it still doesn’t work. Also i try to add as child different blueprints but it still doesn’t work.

Hi expell93,

I attempted to reproduce this but I couldn’t get your results. Can you try reproducing this in a new project and upload it here?

It it’s only reproducible in your personal project, could you try creating a stripped down test version for us?

We haven’t heard back from you in a few days, so we are marking this post as resolved for tracking purposes. If you’re still experiencing this issue, please feel free to post back here with additional information to reopen the post.