Child Actor Component loses Template Section

Hey all!

I am trying to use Child Actor Components for something in UE4.19.

I set the default values under the template section of the Child Actor Component to specific values that I need. At some point, I noticed that whenever I relaunch UE4, the template section is gone and I need to reset the class type in order to get it back. Whenever I do this, all the values are set to the defaults.


This means that every time I launch UE4, I need to go to each of the child actors and set the values to the intended…
For the time being, I have added functions on BeginPlay to set the values as a workaround, but I feel like this shouldn’t be required.

Addition Information
There is only one blueprint that is having this problem. The rest of the child actors (of the same type) do not have this issue.
I have tried replacing the Child Actor with a new Child Actor of the same type and replacing all the references. No luck…
I have also tried adding an additional Child Actor of the same type and giving no references to it. Still no dice…
I have done some searching online and found that people have had the same problem, but no solution is ever posted.