Download

Characters' capsules bouncing off one another

Hey! I have two character that collide while in the air but they just keep bouncing back when they collide with each others capsule components.

Does anyone know how I can make it so the characters dont bounce back off one another but stay locked with each other when they collide in the air.

This is when both character are facing the SAME direction (so both facing right). If they collide in the air facing the opposite direction to one another, they collide fine and don’t bounce off one another. But when they collide the facing the same direction, they bounce off one another.

What I’ve tried:

  • Setting both InitialPushForceFactor = 0 in movement components
  • Creating a physics material and applying it to the capule + mesh that has “Restitution” = 0

Any help is much appreciated, thank you! :slight_smile:

Try setting the JumpOffJumpZFactor on your CharacterMovementComponent to 0.

1 Like

Thanks but I tried this and it didn’t work :frowning:

I just tried it myself, and my method does stop the capsules from bouncing off of each other.

This is the description of JumpOffJumpZFactor:

Fraction of JumpZVelocity to use when automatically “jumping off” of a base actor that’s not allowed to be a base for a character. (For example, if you’re not allowed to stand on other players.)

Are you sure the property has actually been set to zero? Select your CharacterMovementComponent in the editor and confirm that it’s been set properly. When you’re using C++, sometimes the Hot Reload won’t kick in, and sometimes it won’t change properties.

1 Like