Download

Character mesh is bugged (none)

So, I’ve ran into some issues with my character blueprint where the character mesh has become none and unable to be changed. I’m not quite sure what caused it or if it can be remedied so I decided to check with you guys, hopefully we can fix it together!

The character I’ve made is one that has some blueprint-code which talks to the playercontroller and basically creates and possesses another pawn. The code itself works just fine, and I was able to do so multiple times before I decided to save and quit, the next time I opened up the project I noticed that there was no thumbnail for the character pawn but I disregarded it and pressed pay anyway at which point it crashed. I tried multiple times making it work and that’s when I noticed I couldn’t change the character model anymore.

a47fb315ff53c89c4a7f354564122751e9b50b48.jpeg

1536d6af1b36705918074e6c5626731f020f69a3.jpeg

This has happened multiple times now in multiple projects and I’m getting very frustrated as the code runs fine and then when I save, the file is corrupted or something. The weirdest part is that during the last two tries I created a child asset to that blueprint while it was working and when I opened up the project again the original file was corrupt as usual, but the child had the mesh working fine, except that it could not be moved within the blueprint anymore, which is pretty weird.

I’m guessing it might have something to do with me using a custom character mesh and I will check in the future if I remake the blueprint (again) if this happens when I use the regular Hero_TPP mesh, but that’s all I’ve got so far in terms of a lead. Any help is appreciated!

same issue happened this weekend multiple times, It even went as far as to duplicate the mesh twice.
Once this bug occurs, your unable to edit anything(e.g. transforms, etc.)I am sure its only related to 4.5 as this only started happening when I started using the new version. Closing and opening the project helps but like you said its frustrating.(I noted that it happened when I have alot of components and started re-parenting the components)

Hi everyone,

Please make a post on the answerhub at http://answers.unrealengine.com in the bug reports section so we can better assist you. You can find information on filing a bug report at:

https://answers.unrealengine.com/questions/12363/undefined.html

Thank you!

Posted the question here: https://answers.unrealengine.com/questions/115572/character-mesh-is-none-blueprint-broken.html

This issue was solved between the 4.4 version and the 4.5 version in case anyone stumbles upon this thread in the future looking for answers!

I’ve the same problem with 4.7.6