Character is rotating when flying up with up vector


does anyone know how to prevent my chopper from rotating while flying up ?
I know i can disable it if im turning off the “orientation to movement” option, but then, if i want to fly up and to another direction at the same time, it doesnt rotate anymore :confused:

Im using a top down view with a springarm and a camera attached to it.

Anything i missed, or anyone knows a simple solution for it ?