Character Hops when setting Movement Mode

So after my character does something, during the animation I don’t let him move, and right after that I set the movement mode to walking, and everything works fine, except when transitioning from not being able to do anything to being able to walk the character always does a little hop (the default falling/jumping animation), is there a way to set the movement mode so as it’s seamless?

1a4f648642a11fb868b12ea2d82703302f806e50.jpeg

I still haven’t been able to fix this issue, it seems like I’d have to do something else before setting the new movement mode, so the character doesn’t ‘hop’ when transitioning to it.