Changing the default mouse behavior of a PlayerController

I started with the third person template c++ and I am trying to recreate WoW like controls. The fresh project didn’t have a mouse and I thought it had something to do with a default PlayerController so I created my own PlayerController and set

this->bShowMouseCursor = true;
this->bEnableClickEvents = true;

I also created my own

InputComponent->BindAxis("Turn", this, &AMyProject3Character::Turn);
InputComponent->BindAxis("LookUp", this, &AMyProject3Character::LookUp);

which are just calling AddControllerXXXInput

Now I am able to see the mouse but I can only move my camera when I press the left or right mouse button. How would I change this default behavior? I can’t seem to find anything in the PlayerController.

I also find it strange that it knows the left and right mouse buttons because I haven’t bound them in my input settings.

Hi Maikklein,

Here is a link to the Programming documentation page, it may help with what you are looking for: https://docs.unrealengine.com/latest/INT/Programming/index.html.

Thank you and have a nice day!

Adam

Found the two functions that are responsible for this behavior.

https://docs.unrealengine.com/latest/INT/API/Runtime/Engine/GameFramework/APlayerController/IgnoreLookInput/index.html

https://docs.unrealengine.com/latest/INT/API/Runtime/Engine/GameFramework/APlayerController/IsLookInputIgnored/index.html

Maikklein,
If you were able to solve this, it’d be much appreciated if you’d share a more detailed solution. Preferably how you were able to implement those functions.