Download

Changing PostProcessSettings via Blueprint

Hi there,

I have an FPS character blueprint with initial PostProcessing effects that seem to work well.
I tried changing those settings via the BP (for example, changing some MotionBlur-related values while Dashing), by changing my PostProcess component’s Settings while dashing, then changing it back to its default state once the character’s dash is complete (as seen in the attached screenshot).

850d02ce06185764b5f60b812cca2d8d4813cb1b.jpeg

It doesn’t work!
For example - my default MotionBlur Amount value is 0.0, and it should be changed to 1.0 while dashing.
I’m printing the current MotionBlur Amount at each Tick, and it’s always 0.0 (also while dashing).

So, what am I doing wrong here?
If I want to temporarily add certain PP effects for certain character actions - what’s the correct way of achieving this?

Thanks in advance!

Have you tried reading the value of motion blue straight after setting the post process settings?
Perhaps the settings are not being updated.

An alternative way to do this is to have two PP settings variables: Normal And then one for sprinting.

HTH

Edit:
I see now that you have two different settings versions, Have you verified that dash settings are correct?

Wait…
It looks like you are setting the dash PP and then doing a dash which is reverting them.

I would suggest setting the PP settings in the event graph right after the dash check bool.

Ryan hey,

Thanks for the quick reply!

It seems everything you have suggested is already implemented…
The flow goes like this:
I have 2 PPSettings variables, a default one (defPPSettings) and one for dashing (dashPPSettings).
In the event graph, after checking the canDash bool - I set the PP component’s settings to dashPPSettings (sequence’s Then 0), then call the Dash function (sequence’s Then 1), which performs the actual dash, then resets the canDash bool via the timer (calls the resetDash function, which only sets the canDash bool to True), then sets the PP component’s settings back to defPPSettings.

Unless I’m missing something - it already seems to match what you suggested.
I just can’t figure out why this isn’t working…

Thanks again!

What about trying this:
Change the PP settings in the “dash” function, And reset it back to defaults in the “resetdash” function.
That way the motion blur should be enabled for at least one second.

Another thing you can do to test is to make the dash PP change contrast or something visible to see if it is enable even if brief.

But I suspect the sequence nodes are actually enableing the dash PP, But then immediately resetting the PP settings.
So that would result in not visual effect.

It can also be very helpful to use “print string” before/after chaning things so you have a screen and or log message to check with.

HTH

Oh, it seems to work much better when I set the PPSettings at resetDash!
I can actually see it working now, just needs a slight tweak of the timing.

Thank you so much Ryan!@ :smiley:

Your welcome :slight_smile: