Download

Can't use any key

What I’m trying to do is just when you press F (for example) it executes a timeline, but no matter what key I choose, it doesn’t work.
While i’m playing it doesn’t even show that it communicates with the next node and i tried to enable input.

I seem to remember coming across something like this at one point. My problem was that it worked in my player blueprint, but not in other blueprints. I think I needed the blueprint to have a player controller on it, hence it working on the player blueprint. So in short, are you doing this in a blueprint which has a player controller?

It doesn’t work with the player blueprint either.
And i do have a player controller in a enable input node.

Could you post a screenshot of your blueprints?

Just a shot,

if you map a Key say ‘F’ to more than one blueprint, it may not work, as it do not know which node to execute. Remember simulatious execution is fobidden in Blueprint.

Also, see if your blueprint (where you add the input event) default input is set to disable. If so change it to ‘player0’.

How does it matter
it’s just a node for pressing “D” and then a timeline.
everything that i try to do that way, doesn’t work.

btw it’s a top down template if it matters.

I could be wrong, (wish I have ue4 on now) but I think direct key input event cannot be put directly in a function, If you have it in a function, that could be the reason. Just a shot in the dark.

I’ve just created a top down BP project and i get input both from the character BP and player controller. Try to debug this with a Print String instead of Timeline, and post a screenshot of your blueprint setup please.

One more thing, if this is a blueprint (not the level blueprint, and not the character/pawn blueprint), make sure you drag an instance of it into your scene. If it is not part of your scene, nothing will work. :slight_smile:

A few things - make sure an instance of it exists in the scene, as dotcam mentioned, and make sure your blueprint is set up to consume input - Defaults -> Input -> Auto Receive Input = Player0

it’s in the level blueprint.
when i play and look at the blueprint and press the key (tried numbers and almost every letter) then nothing happens.
tried to do it in 4.5 and 4.4 and nothing happens.