Download

Can't go above 1.0 in Distance Field Resolution with Datasmith objects

So CAD objects are much more complex than traditional game optimized objects. This means that there is often very thin geometry, that you still want to cast shadows, even over a great distance.

And since you do CAD visualization, with possibly rapidly changing models, you don’t want to wait hours for baking.

Enter Distance Fields, which seems to be a great new technique. Only, it seems to ignore very thin geometry, even if it covers large surfaces:

Note how the dark roof section here, which is only a centimeter or so thick, doesn’t cast any shadow at all despite covering a very large area.

Now, for these problematic meshes, there’s a Distance Field Resolution slider here:

20181128_153021.jpg

The problem is that I have a lot of these things in my scene, and then I’m going to have even more objects when I’m finished, and it seems that I’m already running into some sort of restriction with memory or size whenever I try to go above 1,0 on this setting:

LogStaticMesh: Error: Failed to allocate 128x105x128 in distance field atlas

That message pops up any time I go above 1,0 and goes away when I reduce the setting again. Apparently there’s a r.DistanceFields.AtlasSizeXY value, but you can’ change it. Does anyone have any other tips for how to get problematic objects to cast a shadow?

I have about 500 square meters, with similar scaffolding placed, and some significant height in places, that I need to visualize (in VR too).