Download

Can't Get Swarm to Work on Two Machines

Hi all,

I’ve been trying to get Swarm to work on two machines, but the coordinator just doesn’t seem to distribute the workload. I believe I’ve done the setup correctly, as the coordinator sees both agents. Either agent can ping the coordinator and each other just fine but, for some reason, they can’t ping themselves. This is what I get when trying to ping from DESKTOP-OFFS0FT:

12:24:22 PM: DESKTOP-IKK0FN7 (User = BMALT, IP = 192.168.1.26, Version = 1.7.2892.0) is currently Available, Assigned to DESKTOP-OFFS0FT
12:24:22 PM: DESKTOP-OFFS0FT (User = BMALT, IP = 127.0.0.1, Version = 1.7.2892.0) is currently Working for DESKTOP-OFFS0FT, Assigned to DESKTOP-OFFS0FT
12:24:22 PM: DESKTOP-OFFS0FT: IP address for this Agent cannot be verified - Coordinator and local mismatch or DNS inactive!

I get the exact same error when pinging from DESKTOP-IKK0FN7, it can ping the coordinator and the other agent but not itself. Likewise, both agents ignore restart orders sent from the coordinator.

The coordinator shows both agents as available, and assigns the one running on DESKTOP-IKK0FN7 to DESKTOP-OFFS0FT. However, I only see one agent when building lighting on the coordinator machine.

So far I’ve tried:

  • Changing DNS settings to have Windows pick one on its own
  • Running the agents and the coordinator as administrator
  • Allowing all agents and the coordinator through the firewall
  • Turning on “AvoidLocalExecution” to force Swarm to send the workload to the other machine
  • Sharing the engine directory and the project files over the homegroup

Just in case, I just tested it in a scene that UnrealLightmass took over 30 minutes to build the lightning for. It even required double the RAM I have. So I don’t think it’s an issue with the workload either. If it helps, both computers run Windows 10 64-bit. One is connected to the network via Ethernet, the other via Wi-Fi. Both are on the same homegroup and can share files just fine.

I’m really running out of ideas here. Would really appreciate any help.

I have the same issue. All PCs are listed in the coordinator, yet no distribution. On top of that, in such situation Swarm fails to start. It seems quite buggy and unreliable. Note that distribution works for rendering in Maya for example, so I really don’t know why Unreal is having issues?!
I have Windows 10 - 64 bit on both machines as well.