Can't download AndroidWorks

UE4 launcher is up to date (so I assume the AndroidWorks-1R1-windows.exe is too).
The latest? tutorial regarding Android SDK installation/setup here doesn’t seem to apply to 4.10. is understandable considering it says “Unreal Engine 4.9” in the heading…

I checked the directory structure of my previously installed 4.9 and it matches the tutorial.


C:\Program Files\Epic Games\4.9\Engine\Extras\Android\AndroidWorks-1R1-windows


C:\Program Files\Epic Games\4.10\Engine\Extras\AndroidWorks\Win64\AndroidWorks-1R1-windows

Regardless, neither of them work for me. During the “Installation Preparation” procedure of each, whether AndroidWorks-1R1-windows was ran with admin privs or not, it gets hung up on “Downloading update lock” for 5 minutes or so and then spits out error:
02-25 16:53:16.1 E: fopen failed, errno = 2 in C:\AndroidWorks.txt

Tried searching for error but couldn’t find info that applies to my situation/UE4.
Both the NVIDIA and folders have write privileges.
No android sdks have ever been installed on machine.

Any help would be greatly appreciated.

I am the OP ( is my home/personal account).
No problem whatsoever downloading from home.

Work PC: Windows 7 64bit, Sophos, UE4 4.9 and 4.10 installed, no Android SDKs installed prior,
default dl/install dir.

Personal PC: Windows 10 64bit, Mbam, UE4 only 4.10 installed, no Android SDKs installed prior,
custom dl/install dir.

Maybe it’s a port/security issue, or maybe the servers were down when I tried roughly 5 hours ago?
I’ll try again from the work PC tomorrow and update post.

Are you able to download from here: [Game Development Tools, SDKs, and Partner Engines | NVIDIA Developer][1]

Game Development Tools, SDKs, and Partner Engines | NVIDIA Developer

Thank you for the link, .

Seeing that launching : C:\Program Files\Epic Games\4.10\Engine\Extras\AndroidWorks\Win64\AndroidWorks-1R1-windows at home went through smooth as butter, I tried it again just now on my work PC and it failed in the same spot (same issue as yesterday).

I followed your link, registered an Nvidia Dev account and downloaded and installed CodeWorksforAndroid-1R4-windows. Unfortunately, after extracting the dled package it too freezes up on “Downloading update lock”, same error in AndroidWorks.txt. 02-26 10:07:45.4 E: fopen failed, errno = 2

(In all attempts at downloading the sdk I confirmed nothing Epic was running in the background.)

Is it possible to take the files that I successfully downloaded at home, and move them via usb to my work computer?
Or do they have to be downloaded and successively installed on the same machine?

You might want to check with your IT department and make sure there isn’t a firewall or anything blocking that program from working. It’s possible it’s set up that way since it’s a work computer.

It’s probably best if you install it from the site so there is less of a corruption.

Since you’re stating that the AndroidWorks program is not working, that is the program that you should be speaking with IT about, if it comes down to talking with IT. What I would suggest doing is posting your question on the Nvidia AndroidWorks forums for additional assistance. The fact that you cannot install AndroidWorks is not an Unreal Engine issue, it comes down to needing assistance from Nvidia.

[Unreal Engine 4 Documentation: Android Works][1]

Thank you.


Oh well. IT hooked it up with :

It was an AndroidWorks issue, but following the tutorial here led me to believe it might not be:

  • version of Android works was designed specifically for use with UE4 Android based projects.*

Seeing that I felt it natural to post in the UE4 forums.

Sorry for the hassle and thanks for the replies, .

Sorry for all the posts. is the final one.

link details the solution to dilemma:

is the final post. The following link describes the solution to the problem of being unable to download AndroidWorks (via PC on a corporate/company network using a proxy server):

Check out the “Note:” under the Downloads and Resources header:

Did their suggestion work for you or are you still having trouble?

	Note: Note that if you are on a corporate network that uses a proxy server, the download process may fail. To work around , you can set environment value http_proxy manually to use the proxy for downloading. 
For example, you can set http_proxy= or http_proxy= http://username:password@ After setting  environment variable, the installer will use the proxy to download the AndroidWorks components.

Sorry, apparently the response I made from work (using my account) stating that “IT hooked it up” (fixed the problem), didn’t stay.

IT set an http_proxy env. var. up similar to your first example of the fix (http_proxy= http{IP address} ) and all is working.

I’m good now.

Would it be too much to ask to have last response of yours have that green checkmark? Therein lies the solution to my problem.

The response that is currently marked as the solution contains a [link][1] to a page detailing info that I had followed prior to posting here. It didn’t contain the info for my fix.