Can't destroy actor that's in an array

Hey everyone,

I’m trying to figure out why I can’t destroy an actor that I’ve added to an array.
In the Actor blueprint, I use the OnBeginPlay node to cast to the GameMode blueprint. From there I add it to an array that I’ve created in the GameMode blueprint [Image Attached].

In the GameMode blueprint I’ve got a custom event that I call from my Player character blueprint.
It’s supposed to destroy the first actor in the array. But I get an error that says it finds “Null”. Even though it’s added to the array. It can’t find the first index for some reason? I’m hoping someone can help me out here! [Image Attached]

What exactly are you adding? The element to be added to the array is missing => nothing is been added => first element is null.

I’m adding an actor.
Which is added on BeginPlay. I’ve tested it using a PrintString node: And it does actually add it to the array.

So, that adding operation is not in the images, yes?

Why aren’t you using “Get”?

I’ve tried using the Get node from the array. But it gives me the same result:
And that adding operation is indeed not in the images. Here it is though:

That’s the same image as one of the above.

The “Add” node has 3 inputs: the execution pin, the array and the element to add.
If you don’t connect the third one, nothing will be added.

The above “Add” has nothing connected to the third pin, so what is the purpose of that node there?

That was indeed the problem. It appears I’ve disconnected that node when I was trying to figure it out myself. Cheers!