Download

Can't compile unreal engine 4 on ubuntu 20.04

I run GenerateProjectFiles.sh and I get this error: ERROR: Platform Linux is not a valid platform to build. Check that the SDK is installed properly.

How fix it? Help me please

I am having exactly the same problem on Ubuntu 20.04.

Setup.sh completes successfully with no apparent errors / warnings but GenerateProjectFiles.sh doesn’t create a Makefile and gives the error you mentioned.

The UnrealBuildTool is failing to find an SDK for some reason - the HasRequiredSDKsInstalled function in UEBuildPlatformSDK.cs can’t find a valid “Manual SDK” or “Auto SDK”.

In my case this was caused by having an old build of UE hanging around with a path that differed to the new build only in case:
~/UE4/UnrealEngine (OLD)
~/ue4/UnrealEngine (NEW)

The Build tool invoked by GenerateProjectFiles.sh in the ~/ue4 copy was looking for the required clang version in ~/UE4 which had an older version of clang. This caused the build tool to think there wasn’t a valid SDK available.

I think this is all because C# file paths are not case sensitive but UNIX file systems are. Removing the old copy allowed GenerateProjectFiles to complete.

HTH

Just ran into this “not a valid platform” error. I ran out of diskspace halfway through one of the scripts, and it obviously didn’t like it. A git clean -xdf and then reruns of the Setup.sh and GenerateProjectFiles.sh scripts fixed the issue