Download

Can't build lighting on 2017 iMac ("LightmapCoordinateIndex" location)

I was trying to create a lighting example for a proof-of-concept for project, but found myself in a bit of loop. The issue is that I’m trying to build the lighting, however, when I build the lighting there is an issue and UE4 tells me to check the message log. I check the message log and it tells me that the “Maps need lighting rebuilt.” Okay, rebuild lighting… enter recursion Hell.

Looking at the documentation it tells me that there are 2 “common” possibilities; 1)" lightmap resolution of 0" - if I’m looking in the right place (LODSystem) then it’s 256 and not 0. So far, so good. 2) “LightmapCoordinateIndex out of bounds” - I can’t find this anywhere. I’ve looked under World Settings, Project Settings, and Editor settings. Where is this setting? I’ve done a few searches and just can’t find it.

Things to consider:

  • I started with the Blank Level template
  • I created a new blank level
  • Lighting in the level - Atmospheric Fog, BP_Sky_Sphere, DirectionalLight, and SkyLight
  • I’m using “Build Lighting Only”

Side note - Right before sending this I decided to try and create another project (Same Actors as above) from scratch just to be doubly sure. This time the lighting build just fails, no message log errors or warnings.

UPDATE:

Since NO ONE is responding, I’ve tried a couple of things.

  1. I installed 4.26, 4.25, and 4.19 (supposedly the best version for Mac)
  • the same issue was present in all versions of UE4
  1. I uninstalled all UE4 versions and reinstalled 4.19
  • It’s acting finicky now.
  • I can create a new project (with assets) but when the project loads there are no assets
  • I import UE assets and BP_Sky_Sphere is missing - my understanding is that this is an Epic BluePrint included for all versions of UE4
    - I could create a new project and migrate it, but that doesn’t work either.
  • Repeated for 4.25 and 4.26 - same results.

×

If I understand it correctly, you tried a default scene in a new project and tried to build lighting and after it built it still had the message that lighting needs to be rebuilt?

If you’re adding your own assets and it’s bringing up errors, then you need to make sure your assets are created properly. For the lightmap coordinate index, that is assigned to each mesh. So you need to make sure your assets have lightmap UV’s created, typically the first UV channel (index 0) is for the textures in your material and then your second UV channel (index 1) is for your lightmap. You can open a mesh and change the lightmap coordinate index to select which UV channel for the mesh has your lightmap UV’s

Sorry it has taken me so long to respond. For some reason, the “Reply” button just wasn’t showing up on the web-page. Not sure why, but… Anyways. I did figure out a solution. Thank you for responding.