Can't add classes, compile, upgrade - Project R.I.P

Hi,

When I tried to add new classes I first had issues with

 LINK : fatal error LNK1181: cannot open input file 'delayimp.lib'

This problem was touched on Answers a few times so I did like others suggested, but it didn’t help. Classes showed in VS2013 solution but did not appear in content browser.

Eventually I found this topic: https://answers.unrealengine.com/questions/176701/cannot-resolve-rc1015-c1083-w-ue470-vs2013.html#answer-209198 Adding paths to VS project helped to fix above problem!

But today I’ve tried to add another class and I got the same error, but here’s a thing: adding paths to libraries doesn’t help. Moreover, somehow I decided to delete the class that was visible in VS but not in content browser(genius :P) and since then I can’t compile, rebuild, add class, can’t do nothing - project R.I.P.
Compile error:

Error C:/The Box/UnrealProjects/TopDown/Source/TopDown/Public/MyAnimInstance.h(24)  : Expected an include at the top of the header: '#include "MyAnimInstance.generated.h"'
Error Error: Failed to generate code for TopDownEditor - error code: OtherCompilationError (5) 

Obviously I’ve tried recreating this class in VS with a proper header but this does not help at all.

Tried this, but it didn’t help:

What to do? I’m clueless, tried everything and I literally can’t do anything with this project.

Regards.

P.S.

Next up I’ve decided to start a new project with 4.9.1 see how adding classes works there and guess what… This happened:

 The project could not be compiled. Would you like to open it in Visual Studio?
 
 Running C:/Program Files/Epic Games/4.9/Engine/Binaries/DotNET/UnrealBuildTool.exe TopDown_4p9 Development Win64 -project="C:/Users/x/Documents/Unreal Projects/TopDown_4p9/TopDown_4p9.uproject" -rocket -editorrecompile -progress -noubtmakefiles
 @progress push 5%
 Parsing headers for TopDown_4p9Editor
   Running UnrealHeaderTool "C:/Users/x/Documents/Unreal Projects/TopDown_4p9/TopDown_4p9.uproject" "C:\Users\x\Documents\Unreal Projects\TopDown_4p9\Intermediate\Build\Win64\TopDown_4p9Editor\Development\UnrealHeaderTool.manifest" -LogCmds="loginit warning, logexit warning, logdatabase error" -rocket -installed
 Reflection code generated for TopDown_4p9Editor in 10,7835056 seconds
 @progress pop
 Performing 9 actions (4 in parallel)
 [2/9] Resource PCLaunch.rc
 [3/9] Resource ModuleVersionResource.rc.inl
 PCH.TopDown_4p9.h.cpp
 C:\Program Files\Epic Games\4.9\Engine\Source\Runtime\Core\Public\HAL\PlatformIncludes.h(5) : fatal error C1083: Cannot open include file: 'new': No such file or directory
 C:\Program Files\Epic Games\4.9\Engine\Source\Runtime\Core\Resources\Windows\ModuleVersionResource.rc.inl(3) : fatal error RC1015: cannot open include file 'windows.h'.
 C:\Program Files\Epic Games\4.9\Engine\Source\Runtime\Launch\Resources\Windows\PCLaunch.rc(10) : fatal error RC1015: cannot open include file 'windows.h'.
 -------- End Detailed Actions Stats -----------------------------------------------------------
 ERROR: UBT ERROR: Failed to produce item: C:\Users\x\Documents\Unreal Projects\TopDown_4p9\Binaries\Win64\UE4Editor-TopDown_4p9.dll
 Total build time: 25,62 seconds

Hello OutOfMyMind,

Have you tried installing the Windows SDK? This error (Error code RC1015) normally coincides with that. Does your windows user name contain any special characters such as “å”? If so, this could also be causing problems for UAT when trying to locate the include file windows.h.

Hi ,

Installed WSDK, had some problems with installation - because I have .net 4.5/4.6 installed, but eventually I installed C++ compiler. I dont use special characters at all.

Nothing has changed, still cannot fix my project and I can’t create new C++ projects.

I have a diagnostics file I would like you to run that gets information about your Visual Studio 2013 install. You can find it attached. To run it, you’ll need to remove the .txt extension (Answerhub doesn’t allow uploads of .bat files) and run it as a .bat. It’ll give you an info.txt file. Could you respond with that info.txt attached? It may be helpful in pointing out the issue.

OK. So there is an error in that file.

Googled that and I changed enviromental system variable of “Path” to the “C:\Windows\system32;”. So now I can create new c++ projects, I can even create new c++ classes without problem! So there’s progress.

But that haven’t fixed problem of my existing project. Any way to fix it?

link text

here is a info after changing “Path”

link text

For your existing project, can you try deleting the Intermediate folder and the .sln for the project followed by right-clicking the .uproject file to “Generate Visual Studio Project files”? If it is only happening for that project at this point, it may be something to do with the project’s settings in Visual Studio.

That fixed some errors and that helped me to fix some other errors. Project recovered :slight_smile:

Thanks !