Cannot rebind grid zoom keys

It seems zoom keys (maybe others?) cannot be rebound.

Reproduce:
edit>editor preferences>general section (keyboard shortcuts) > search for zoom and find zoom in/zoom out and set to any other key than numpad -/+