Cannot compile unreal with visual studio

Hello everyone,
A couple of days ago i formatted my system and i did a clean win 8.1 install. Now every time i try to compile Unreal using visual studio community 2013 after one tenth of a second i get this message and nothing happens.

Have i forgot to install something? I have compiled unreal using this method more than a dozen times before.Now it just gives me this message.Any ideas of what is happening?

Thanks!

What do you mean by “this method”? Have you tried “Build Solution”?

If i right click at the EU4 icon and i choose build then after 1/10 of a second visual studio gives me a message that says(see picture)" your build is successful" without actually building anything.

Hey Roccinio-

Is there any difference in behavior if you set the solution configuration to Development Editor and try to build again?

Hey Doug!

If i understood correctly what you are asking there is no such option anymore.The closest i get to what you are suggesting is just a plain :development"

And no matter what i choose i get the same results.

Did you try to regenerate the UE4 visual studio project?

Do you mean rebuild my project? From right clicking in the EU4.sin file that is inside visual studio?

Which version of the engine are you using? You may want to try pulling the latest promoted build from Github and re-run the batch files and try building the engine again.

It is the latest promoted and i have tried this with 3 different master branch releases + this one.It behaves exactly the same! In the beginning i though that i downloaded a bogus master release (it happens) but as soon as i saw that this is happening with yesterdays promoted as well i decided to ask for help.

You could try using the Releases branch since that will be more stable and reliable than the promoted or master branches. If you are still unable to build the engine I would suggest trying to repair or reinstall Visual Studio. Let us know if you’re still having troubles after that.

I deleted everything,cleaned the registry,re installed visual studio express, re downloaded a couple of releases from git and i see the exact same thing as above! This is super weird. It says build succeeded without actually building anything

I need some help with this. I re formatted my pc, updated everything and i still cannot compile. It just does not give me all the options like development Editor.

I installed visual studio on my win 8.1 tablet, i used the exact same downloaded master branch release and it worked right away! I could see all the options and it started compiling! WTF???

I am certain that i need to install something more for it to work .It doesn’t make any sense. Can you please tell me what i need to download as extra so i can be able to compile unreal through visual studio? (example: all versions of directx, .net 3.5 etc, an option inside visual studio)

Thanks in advance.

Is there any reason why you do not use the Community Edition of VS? That might have a stronger installer. Either way, if you re-run your installer, there should be a repair option for VS.

You could also reset your Visual Studio options:
Tools->Import and Export Settings->Reset all settings.

UE Software Requirements.

You could do an official Win 8.1 refresh or reset. Press “Windows key + S” than search for “Recovery options”. (Create Win 8.1 reset/refresh media, USB/DVD install tool)

Thank you for your reply. I am indeed using community edition of vs. I have formatted and re installed my os 2 times. This is so weird. Can i please ask for something? In the solution explorer inside VS it says "solution UE4 (20 projects). Is this the right number.I think it was higher before. Could someone verify this for me?

The problem has been resolved but i do not know why and how.After the 100th time it decided to work. Just like that.

Thank guys!