Can you lock the FPS?

I was wondering, since I’m currently getting 120 FPS lol!

Now, this is a good thing, but can that hurt the computer in anyway? Making it work harder than it should be? Is there a way to lock it?

not that i know of. what i use is a program called Dxtory link text

It has an option in it that you can limit framerate works on most any program though that only works for you. :-p but some sort of option to limit framereates would be useful though :-).

type in the console t.maxfps 60.0 to lock to 60 fps. To open the console, in the Window menu, activate the log window.

Does this persist when closing and reopening the editor?

#Config/DefaultEngine.ini


There is a simple solution to this!


no need for external programs!

you can lock the Editor FPS like so

[/Script/UnrealEd.EditorEngine]
bSmoothFrameRate=true
MinSmoothedFrameRate=5
MaxSmoothedFrameRate=60

Enjoy!

Rama

PS: yes it persists forever

#Wiki page

I added wiki page for this

A new, community-hosted Unreal Engine Wiki - Announcements - Unreal Engine Forums,Editor%26_Game#Commenting_Stuff_Out

Thank you Rama. Is there any way to apply this change to the engine itself rather than one project at a time?

Engine/Config/BaseEngine.ini

Should do the trick.

You da best Rama! My PC and I thank you ;D

After updating to 4.2 this is no longer working for me. I used to do this in each update up until 4.0.2 by adding the code above to the BaseEngine.ini file.

I have tried using just the new option in Project Settings->Engine->General Settings->Frame Rate

and

I have tried using the above setting with adding the above code into the BaseEngine.ini file

Neither has worked.

Please advise, thank you

Any ideas? My computer sounds like the Large Hadron Collider while I’m making FX at 120 FPS lol.

Anybody…?

Hi Matt,

No, this method does not persist after reopening the editor. But you can implement Rama’s fix in 4.2, it’s just a little bit different. That bit of code is now hard-coded in, just change the values I have highlighted and it will lock in the FPS.

Hope that helps, TJ

I’ve been away so I haven’t had time to try this or respond, but I wanted to thank you for taking the time to answer my question sir.

What about Vsync is there a way to turn on Vsync?, that should limit the FPS to the sync of the monitor.

Hey DCrosby,

You can force vsync on by running from a shortcut or commandline with -vsync.

Ben Halliday

You’re very welcome. Have a good day. :slight_smile:

TJ

Finally got around to trying this, it didn’t do anything for me. I changed the values in C:\Program Files\Unreal Engine\4.2\Engine\Config\BaseEngine.ini

Also, is it just me or does the frame rate setting in Project Settings->Engine->General Settings->Frame Rate do nothing?

Hi Matt,

I just tested this in 4.2.1 and it works. I changed the BaseEngine.ini just as it is pictured above.

Did you restart the editor after you saved the ini file?

Yeah I did, here’s the line in my file.