Download

Can UE 5 Early Access work on Mojave 10.14.6?

Hi! Has anybody been able to install UE5 early access on Mojave 10.14.6 or is it requiring Catalina?