Download

Can anybody clear up how to use Oculus Dk2 with UE 4.11 ?

Looks like 4.11.2 have updated it’s oculus libraries to 1.3.0, and does not work with oculus runtime 0.8.
I tried to install latest oculus runtime for PC, it downloaded 800 megs of something and say my DK2 is not supported, yek.
Then after all it hanf in headset configuration mode with no other options.

Developer sdk libraries are now just zips, and i have no ide how to use them.

Can anybody clear this stuff? What should I download and install to use my DK2 with 4.11.2?

you need to install the 1.3 runtime.

however, I’m getting an issue where my dk2 screen is just in the “white room”, no idea there.

But how I can install it? Do you have a download link?
Oculus site provides with some web OculusSetup, and i have no idea which runtime it installs, also it does not work after that/

I can not setup my DK2 because Oculus wants it’s Sensor. :mad:

I use the same configuration so I’ll share my experience with setup which might help. I first had to uninstall the Visual C++ 2015 x64 runtime before Oculus Home would install properly (it includes 1.3.0 runtime), and then I allowed unknown apps in the settings. I have to manually launch Oculus Home before UE4, and it will put me in the white room with the message, but sometimes it appears 90 degrees to my left, or directly behind me. Also sometimes it won’t activate the sensor so I have to unplug it and plug it back in. After that it works fine.

I have been having issues getting oculus home instaled, for me oculus store will not open, was this a similar thing for you and why you uninstalled Visual C++ 2015x64 runtime?

I’ve just been using the standard current runtime. The store will tell you your DK2 is unsupported, but that’s just their way of telling you anything you buy isn’t really built with your particular headset in mind. It’ll still work fine in UE4.

SAP BOBJ 4.1 Training Online
Ashok
Contact numbers : +91 9972971235(India)
Email Id : Madhukar.dwbi@gmail.com
Website: http://sapboonlinetrainings.com/

I uninstalled the runtime because the Oculus Home installer would properly download all the files needed for installation, but then fail to actually install them once it tried to install its own 2015 x64 runtime.

I just installed Oculus home which I downloaded from the Oculus website. During installation, I got a couple of messages saying that tracking might not work since I use USB 2.0 ports (which isn’t correct, I have it connected to USB 3.0 ports), but everything works fine. Make sure to uninstall any previous versions first.

With the new software, it’s a little different from before. The Oculus program needs to run in the background all the time you’re using your Rift. To get UE4.11 to run, I just start it like I’ve always done, nothing special at all. Then launch it in VR preview window. Everything works perfectly for me.

When you first activate the VR preview, you’ll see the “white room”, which is the new warning screen. Just look at the bottom text frame and press A on your xbox controller to make it go away. It’s probably possible to press other keys to make it work, but I haven’t tried that.

Mine Oculus stuck in Rift Hadware Issue -> view in VR -> no sensor attached, mode. Once I saw the store and messages like my DK2 is unsupported, but then somehow managed to put it in that Hrdware Issue mode. Reinstalling Oculus does not help, no more step by step wizards and other stuff.

Mine does that too, I can fix it by unplugging and plugging the sensor back in. Try using a different USB port, I just remembered I couldn’t get mine to work until I switched both to USB 3.

Fixed by stopping OVR service, deleting all Oculus folders in my AppData/Local and AppData/Roaming folders. then oculus restarted and setup wizard reappeared.

To those getting the warning that you’re not using a USB 3 port: I got that warning when I installed the Oculus software, but everything works fine nonetheless. I also have a warning in my Oculus home all the time that DK2 is not supported, but I haven’t find a single program or function that hasn’t worked, so I think it’s mostly a way for Oculus to not have to answer for any problems that might arise, so mostly a legal thing. So, before you try anything else, test if it works or not. If it still doesn’t work I’m sorry I can’t help since all my installations have gotten the error messages and all of them worked flawlessly.

Bit late with this. I struggled with the dk2 sensor showing up as a camera. I installed the drivers while in unsigned drivers safe mode and the camera shows up correctly (I think it may have been a Windows 10 fast ring driver signing thing)

I’m using 4.11.2 with DK2 running Oculus 1.5.

At first, the VR preview screen in UE was black and my rift was the gray default. I read somewhere that you may have to look 90 degrees right or left and sure enough I looked right and there was some text. After I clicked the controller A button my preview works from then on out. I will say it took me a few attempts to figure that out but once you do there is no issues. Also make sure in Settings > General you set Unknown Sources to enabled.