Download

CAMERA 360 System (Blueprints)

Thank you! Please keep me updated as a 360 video 2D looks so plain that, immo, is not worth it :frowning:

When I set camera in smoke there is a clear borderline on picture ,how to Solve this

Hey,

I just bought the pack. I just wanted to ask about the workflow of capturing a 360 video render. I want to capture a 4K resolution 75FPS video that is 3 minutes long. I want to start the video capture through blueprint, let’s say a keyboard click for now. How would I go about this the quickest and least painful way? It is for VR by the way.

Oh and last bit of information, my camera component right now is following a custom spline. I’d like to record from that camera’s world position and rotation perspective.

Best Regards,

Jem

Hi! Unreal Engine 4 has its own features. Are you using a particle system as smoke?

Try to use a 3D model of the smoke. Each particle looks towards the camera, in our case we have 6 cameras at different angles, because of this there is a seam visibility. Or try using smoke in places where there is no seam.

In camera 360 actor there is a check mark, show debug borders.

  1. I want to start the video capture through blueprint, let’s say a keyboard click for now.?

Watch the video tutorial. Initially, don’t forget to set the folder for your images, frame rate and texture resolution.
For best quality settings - Render Target = 4096 px ( link settings ) and size image 7680x7680. To use blueprints to record, You need to use the HighResShot system https://youtu.be/J7uEiOhkH8o . Initially, you can start your project with the Play button, then at the right moment press the R-button to start recording the rendering in 360.

  1. Oh and last bit of information, my camera component right now is following a custom spline. I’d like to record from that camera’s world position and rotation perspective.

you can click on the camera point 360 actor and specify a tracking target, such as your actor, which is attached to the spline.

  1. I just bought the pack. I just wanted to ask about the workflow of capturing a 360 video render. I want to capture a 4K resolution 75FPS video that is 3 minutes long.

You can also use the Sequencer system. Watch the video tutorials, I’m sure they will help you and give answers to your questions.

I am not using the sequencer by the way. So since 7680x7680 your recommended settings, I should disable Aspect Ratio 2:1?

Also this is all for VR so any other setting I should check in your plugin?

Even if you don’t use a sequencer, the sequencer allows you to record video.
https://youtu.be/okfRmZjPxbM

If you specify an Aspect ratio of 2:1, the output image size should be 7680x3840.

If you specify an Aspect ratio of 1:1, the output image size should be 7680x7680 . If you specify 1:1, the picture will contain more pixels.

Hi Elizza, I really like your plugin, but I have problems with anti-aliasing that would be great to solve! I read the problems with the temporalAA and set the MSAA but I don’t get good results. With the latest version of unreal the dof method has also changed and I can’t try your advice with the boken at 0.002. I have some trees in the scene that are not clear if they do not have the time. Is there no way to use the TemporalAA filter? why doesn’t it work? Thank you

Thank you, I’m glad you like the plugin. Do you have an example scene? It would help me a lot and I would check everything.
If you set the temporary AA mode, your picture will be blurred.
MSAA allows you to get a clear picture.

You can try to use Temporal AA, but with the HighResShot System, I added a new feature in it.
You need to tick raytracing.
Please see tutorial https://www.youtube.com/watch?v=XAT3CwxCP08

News 11/30/2019. Tutorial. Master Sequencer.

You can use Your customized cameras using the** Master Sequencer **

Opened Unreal Engine Assets 360 used Camera 360. On this channel you will find information on how much time it took to render frames, what settings are applied when rendering the camera as well as colorful presentations of unreal engine martetplace assets.
https://www.youtube.com/channel/UC-65FNFxz31v8xDtz-Je3cw

hello, I followed your instructions and activated raytracing.
I use an RTX 2080 but I still have the cartoon effect using the temporalAA filter.

I am attaching two partial screenshots of the image at 100% of the size:

1.TEMPORAL AA:
[ATTACH=JSON]{“data-align”:“none”,“data-size”:“full”,“data-tempid”:“temp_178397_1575283419216_312”,“title”:“test-TemporalAA.JPG”}[/ATTACH]

  1. MSAA: [ATTACH=JSON]{“data-align”:“none”,“data-size”:“full”,“data-tempid”:“temp_178398_1575283456719_325”,“title”:“test-MSAA.JPG”}[/ATTACH]

Thanks for your help

Good day, alb3360!

I can’t see the images, maybe they were downloaded with an error.

Can you repeat and attach the images?

Sorry…

temporalAA:

MSAA:

Do you have the opportunity to direct me a small scene so that I can conduct experiments to achieve the best smoothing quality? Link to the project, please send by personal mail. Mail: [EMAIL=“Lenina62-ivan@mail.ru”]Lenina62-ivan@mail.ru Do not worry about confidentiality, after help, I delete projects.

I would also like to see the settings of the 360 camera. Can you send me an image?

I will find some resource to check possible anti-aliasing options. I will write to you later.

Have you tried setting up the camera like in this video?

https://youtu.be/LyFImwdKqME

To avoid seams, Post Processing settings are applied.
Settings Post Process for Camera 360:

  1. Vignete: 0
  2. Exponecial Heigh Fog : Volumetric Fog Off
  3. Ambient Occlusion: 0
  4. ScreenSpaceReflection: 0
  5. Bloom: 0

Camera 360 settings: Aspect Ratio: 1:1
Output: Frames: 3614 frames
Rendering time: ~ 1 hour 33 minutes
Rendering 1 frame: ~ 1-2 second
Render Target Texture (Quality): 4096 Px.
Size Output Image: JPG, 7680x7680

I very often apply quality to get 8K and 4k video.

hello, thanks for the help! Yes I set these parameters but I still have that cartoon effect. if we solve it I would be very happy … The scene is very light and changes from the images I sent you, but I have the same problems! I’m sending you the file with wetransfer. regards

Hi! I understood you. I saw a letter. Now I’ll check everything and write to you later.

Good day!
I managed to find a problem where TemporalAA smoothing did not work. Now I’ll check everything, if everything goes well, there will be anti-aliasing in the new update.

News 12/09/2019. New update 1.13 fix 5.
Added the ability to use the correct anti-aliasing TemporalAA.

In the project settings (Edit -> Project Settings -> Rendering) , Anti-Aliasing the TemporalAA smoothing method should be selected.

Now you can disable and enable anti-aliasing if required in option Camera_Rec_360 actor.

AntiAliasing_TemporalAA_Value.png

This video - new corrected Anti-Aliasing TemporalAA method.

Good job! and great support! thank … You solved my problems!