Download

CAMERA 360 System (Blueprints)

Hi, ElTioPanZeta!

Try off Screen Space Reflection in post process.
Sometimes material using screen space for effects and you see seams when used camera 360.
sometimes it is very difficult to do this if the material shader uses screen space.

Did the solution help you?

Hi I use 360Mono (Use 6 cameras)
Custom Render (true)
FullPostProcess(true)
Found many seams

Hi!
Next step:

  1. Open Your Post Process
  2. Vignette = 0, Bloom = 0, Exposure → Manual .

Video tutorial Tutorial 3. Camera 360. Seams. PostProcess settings (New version) - YouTube

Hi Ivan. Hair simulation is not working with 360 camera but works with normal. Is there a trick to make it work?
Here are examples:

Hi, Max!

Yes, Tell me in which version of the engine do you work?

I have already seen such a problem. This problem occurs when working with the engine from Epic Games Launcher.

Do you have the option to install the engine from the source files of UE, GitHub?

Hair Physics works in version 4.26.0. Unfortunately physics doesn’t work in 4.26.1 yet.
Solution:
You need to download the source codes UE4.26.0 via Epic Games. You need to have a GitHub account for download source code

https://github.com/EpicGames/UnrealEngine/archive/4.26.0-release.zip

Mine is 4.26.2.
Thanks for reply Ivan! I’ll try it.

Always happy to help!

Hi, after testing here, I found that there are still some seams
I use Camera_360->Map->Demo_Scence_DOF scene this time

Bloom Intensity =0
Exposure Metering Mod=Manual
Exposure Compensation=10.8
Lens Flares Intensity = 0
Image Effects Vignette Intensity = 0

Hi!
That’s right, you need to reduce the intensity of the DOF. Otherwise, such seams may appear. Since screen space is used for this effect,

News 10.13.2021. Fix update for 4.25-4.27 .
Now the panoramic capture plugin works correctly.

Hi,
i am trying your plugin with Ue5. i made copy and paste of the folder camera360 from Ue4 to the content folder of my Ue5 project.
i dont have any of this BP in Ue5 : camera_point 360. camera_rec360 and camera_point2d.
do you have any idea ?

thank you

M.°

Hi!
Yes, you need create project in UE4.26, and convert to UE5 and check. If you convert UE4.27 to UE5 (actors not support and not working) → Incompatibility of version 4.27 and UE5.

Hi,

I’m having some issues with the some of the textures in my level when the Camera_Rec_360 and Camera_point_360 actors are present.

When I first load the project and level, the textures on many of the static meshes in the level are frozen at a lower mip (they appear pixilated and blurry).

When the Camera_Rec_360 and Camera_point_360 actors are not present in the level, the textures load fine.

I suspect that something having to do with my project settings and/or the SceneCapture2D and Render Targets used in the Camera 360 blueprints may be causing this.

Does anyone know of a command to force-reload all textures to the highest resolution? Or is there any way to configure the Camera 360 blueprints so that they don’t block other textures from loading?

I have noticed the error in both UE 4.26 and 4.27.

David

Hi!
Don’t worry. This problem solution:

  1. Open Project Settings
  2. Find Texture Streaming and False
  3. Restart Projects.

Thanks @ElizzaRF !

Thank you ! works great.
i have another question.
Lumen work with the camera you suggested ( camera_point2d and camera_rec2d) but is it possible to render with the sequencer then ?

thank you

M.°

Sequencer or Movie render is not supported yet.

Write me an email Lenina62-ivan@mail.ru , I will send you a slightly improved version for Lumen. It reduces the noise on the images.

Thank you !
i just send you an email about that.

M.°

Hello!

I’m using this plugin at work to render an interior 360 / Mono / Raytracing. The interior is quite dark in some corners and I need Raytracing GI to get into those corners to light them up a bit.
The problem is - it seems:
r.GlobalIllumination.Denoiser.TemporalAccumulation - this doesn’t seem to work right?
Sadly this is possibly the only way for me to get the GI flicker free, since I have already increased the samples to high amounts and even those don’t fix the issue, while producing crazy rendertimes.
Am I doing something wrong here or is it correct that the Denoiser and Temporal Accumulation isn’t working?

Thanks for any help!

Best

Hi, Behrendt!
Can you email me Lenina62-ivan@Mail.ru and send me a scene?
I’ll check everything and write to you.
You try all solution (TAA)?
Tutorial 27. Camera 360. Rendering 5 Solutions - YouTube
You try this solution PathTracing in UE4.27 ?
Tutorial 28. Path Tracing 360. Camera Point 2D and Camera Rec 2D. - YouTube