Download

CAMERA 360 System (Blueprints)

Unreal Engine 4.22 Release.
The product works in this version of the engine 4.22

, everything is fine, but in version 4.22 SceneCaptured2D the visible button does not work, because of this, all used cameras are displayed.
Recommended all SceneCaptured 2d in actor Point 360 to Scale 0.0001 .

For version 4.22, an update file will be added soon. You don’t have to do anything.

Example:

Pelco’s panoramic IP cameras provide coverage of a wide, horizontal area to detect the activity of people, vehicles, even wildlife. Our multi-sensor and single-sensor fisheye fixed cameras give you total situational awareness

Hey, does this support post processing materials? I need to do a 360 video with outlines added by a post processing materials.

Do You have an example of your material, so I can test it?
You can send a test scene with a customized post-process. I can check and record a video for You.

Work with post-processing. The actor was attached to point 360.
There are two options.

  1. You can attach a cameraactor 360 to an actor point 360. If You have a very large number of post process.
  2. You can place the camera actor 360 in the post-process zone.
    And watch the tutorial video https://youtu.be/1gVYSt7LGMU

360 Mono mode + Post Processing (without screen space reflection) (target 2048 px rendering): https://youtu.be/LzgZWd1OP0M
360 Mono mode + Post Processing + reflection space of the screen (render target of 2048 px): https://youtu.be/JPoE_r5r9AY

Hi.
I’m trining to play a video file while capturing and always results in dropped frames while playing the video.
How I could solve this problem?

Hi!
Try using any video editor to slow down the video file, for example, 10 times slower.

Then try rendering and see the result.

The problem is Unreal Engine 4, in real time mode video files play correctly, but if in delayed frame rendering mode, then the video file remains unchanged, because of this video file plays very fast.

Excited to try this plug-in as an alternative to Ansel but having disappointing results at first. I’ve attached an image. My 360 capture has this flickering square that appears randomly in all directions for a frame or two and then disappears. This is a starter level with everything at default except for the 360 camera blueprints added and rendering out with sequencer.

@ElizzaRF, any thoughts? I’m probably doing something silly.

Thanks.

Good day!
Thank you very much for purchasing my plugin. I am sure We will find a solution.
Please go to the first page of the forum.
https://forums.unrealengine.com/unre…49#post1598649
It contains information about 6 possible solutions for getting rid of artifacts.

If you are rendering through a sequencer, try method 1. This will reduce the load on the video memory.
And write me please the specifications of your computer.
Please tell me at what resolution you render the footage, what format png or jpg?

Specs:
i9-9900k
64GB Ram
GTX 1080TI
Windows 10

I will try some of the other rendering methods.

I’m rendering PNGs at 8k.

Very strange, you have excellent system requirements of the computer.
I had artifacts in very complex scenes and png. video card gtx1060. But this was rare.

Can you check the plugin in any of your projects?

Try the quality of the output JPG file ?
You can change the RenderTargetTexture 2048 px values to any other value to change the quality either higher or lower.

The path where you store the render target texture.
Camera 360/textures/

Tell me please, did The solutions help you?

It definitely seems to be a resolution based problem with the video memory. Out of sequencer 4096x4096 resolution for Mono capture has NO artifacts but 7680x7680 has many every couple frames.

Can you explain what “manual capture” is in your list. I see the check box but do not understand the method to activate and use it.

This is a clean project on a brand new computer.

Thanks.

For sequencer: Try to make a resolution 6000 px ? And put render target 3000 or 4096 px . The quality will be as 8k. Will there be artifacts?

Method recording #2: Manual Rec mode.
You need

  1. Select actor camera 360 Rec.
  2. choose the size of the image.
  3. Tick Screen Shot Rec
  4. Specify a frame rate of 30 or 60 frames.
  5. Specify the number of frames, for example 30 frames.

When you press the start button, the system will automatically start recording.

In this mode, you can only record in PNG format at any resolution without restrictions.

The files are saved to the path : name project/saved/screenshots/Windows/

Tutorial https://www.youtube.com/watch?v=D4G5y_kOkkA&t=104s 4 min 55 sec.

There is another solution. You can try to make a manual method in the Packed project.
But be sure to check the entry and the number of frames.
I’ve heard that in game mode it consumes less computer resources than in editor mode.

Can you create a new project and remove atmospheric fog and exponential height fog and test the scene through a sequencer in 8k?
And update the drivers for your graphics card.

Hi Elizza, thanks for your quick response.
i’ve found a manual trick just setting a rate function (with 0.01 value) to my media player in level blueprint and it seems to be working well.
The problem is that value should be different depending on recording frame rate, but for now this is a quick solution.

You’re right! Thank you for the decision, I think it can be useful for those who will have the same question =)! It’s really much faster

Update 1.11 Small changes.

  1. Fixed scene captured 2d size from 1 to 0.0001 for version 4.22.

Thank you very much Suk Young Choi, helped to find another post processing, from which appeared seam.
The seam is difficult to see, but when you turn on bloom, it may appear from behind.
This does not interfere, but if You need to remove it, just change the value of bloom.

Decision. To put the postprocess bloom=0.

**Small note. **
If You notice that the image is blurred when moving.

View lesson Tutorial All System. Camera 360 - camera system for video and screenshot (360, Stereo, Mono and 2D). - YouTube 1 min 30 sec.
You need Project settings => Rendering => Anti Aliasing method = TemporalAA to MSAA.
The picture will be clear.

**News 02/05/2019. **
Added new tutorial image sequence editing in Adobe premiere.
Work with 360 image sequence with adobe premiere. As a result, you get a video file that contains 360 meta tags. Final video can already be published on youtube, or viewed in a 360 video player.
https://youtu.be/1UKh0bXI8GI

Hello

I’m making an app in unreal engine for oculus go where you view 360 stereoscopic images and I’ve got the materials working whereby the image is split to each eye and give the stereoscopic effect but my issue is the images look really blurred and low resolution. Even at 4096 x 4096 I can see some anti - aliasing issues around the objects in the images but at 2048 x 2048 it is especially bad and that’s the bulk of the images that I have.

Please help