CAMERA 360 System (Blueprints)

@ElizzaRF Thanks a lot for the support, and quick reply!
Before I posted my first comment, I used Get Target All Transformand to select the camera, but it didn’t seem to recognize, or update the connection between the two objects. (By the way, I’m using 4.25.1 version).

But anyways, I managed to get a capture working in the meantime by adding the “Camera_Point_360” object itself into the Sequencer like in the video link you provided, and managed to export a nice panoramic sequence. So this method seems to be working fine!
The tutorial you linked, by attaching “Camera_Point_360” to a CineCameraActor in the Sequencer, and deactivating the Track also works. Regarding this method: is it possible to animate camera exposure? I can’t add Camera Component to “Camera_Point_360”, and it does not seem to adapt animated exposure from the CineCameraActor.
Neither adding PostProcessVolumes to the level, seems to have effect on the rendered output.

Also, a question: Is it possible to narrow the Field of View, for Dome Camera, or VR180_Stereo outputs?
We are making a VR animation for Oculus Go, which seems to have an upper limit of video resolution 3840x3840 or 5760x2880, which does not seems to be enough for a VR180, so I’m thinking of projecting the rendered video on a smaller segment of a sphere (for example 135° by 135°), so like this we can make a better use of Oculus Go’s maximal video resolution.
Of course I can capture a full 180° at a higher resolution, and crop the image sequence afterwards in a video editing software to have a more narrow field of view, I’m just wondering if there is a more effective workflow for this.

Thanks for the great plugin and for the support in advance!

Hi, Narmer Visual!

  • I am glad that you managed to do everything! :slight_smile:

-1. Open sequencer;
-2. Add in scene PostProcess and Add to sequencer;

-3. Select PostProcessing -> Lens Exposure -> Exposure Compensation;
-4. And add key in your timeline, try frame 1 = value 0, frame 10 = value 1.
-5. Don’t forget. Infinite Extent(Unbound) for apply the post process to the entire level. And all working. Or Actor camera rec 360 paste to post process zone.
It is better to do this through the post process, so that all cameras that are used in camera 360 have the same exposure. And it’s better to do the Manual method.

I need to think about it. Thank you for the idea, but now unfortunately there is no such opportunity to reduce the field of view.
I am constantly working on improvements and always happy with new ideas.
Thank you for your kind words and purchasing the 360 Camera. I’m always ready to help :slight_smile:

@ElizzaRF Thanks a lot for the support, I managed to get it all working!

Hi, Narmer Visual!
Thank you so much for your kind words :slight_smile:

First, thanks for this plugin! I’m really excited about it.

I used the ArchViz Project from the Learn tab, but there is quite a bit of noise, especially on the ceiling and walls, but not so much in other places. I don’t have a top of the line computer but is good. i9 processor and RTX 2080 max Q (MSI laptop).

My best guess is, is that I can’t seem to put the Texture quality over 2048 without it crashing, I’ve tried changing AA, I’ve tried using the high-quality settings as well and those don’t seem to make a difference.

Do you have some ideas?

Good afternoon, michalex19!
Thank you for your purchase. Email me if you can’t apply these settings.
You have a great computer, but since raytracing is very demanding, you need to set the settings very carefully.

***You have several ways to create a rendering. ***

  1. Movie Redner Pipeline (In Unreal Engine 4.25) (youtube tutorial)
  2. Add in scene acotrs (content/Camera_360/Blueprints) : Camera Rec 360 and Camera point 360
  3. Select Camera Rec 360 and change settings:
  4. Change settings in Post Process:

4. Open Movie Render Pipeline
5. Select Master_Sequence . Don’t forget attached your Camera Poin 360 to camera sequence (tutorial)
6. Select New preset settings:
7.Add settings, Antialiasing (Sample count = 2) , High resolution (Tile count = 3), and output
8. Accept and Start Rendering.
This solution best clear image full raytracing used Movie Render Pipeline.
Example youtube tutorial.

  1. HighResShot system (youtube tutorial) .
    Not clear image GI.

Tell me, did the solution help you? If not, write to me personally, I will contact you online. [EMAIL=“”]

I lost my project with settings. I will publish an accurate video lesson soon to avoid noise. Please waiting video tutorial.

Hi, I just wanted to be sure if the Camera 360 is guaranteed to be “frame lock”. Means that the game-play fps is lock to the rendering fps (like 24 fps for instance) and it cannot have frame de-sync because of a game-play lag, … So that two different rendering have the exact same frames and timing. Can you guarantee that ? Or you know it’s not “frame lock” ?

Hi, corentin-dpt!
The first 5-10 frames at the beginning of rendering may be black, as the 360 camera is activated.

There are 3 rendering methods in Camera 360.

  1. Sequencer ;

  2. Movide Render Pipeline
    Here all frames correspond to the frequency specified in these systems. If 24 frames, it will do 24 frames per second. If 30 frames, it will do 30 frames per second and so on. Freeze frame is not used. There are no missing frames.

  3. HighResShot system and Custom Rendering
    The timeframe may differ by several frames, since the game is suspended. But not much. If the window is not active, frames may be skipped. This is why the window must always be active. You cannot use other applications.

All systems there is no desynchronization. That’s right, even if your scene is very heavy, only 5 frames per second, rendering will have a specified frame rate, such as 30.

NEWS 07/24/2020. DOF (Depth of Field) for UE4.23, 4,24 and 4,25.
I’m running depth-of-field tests. I’m still checking everything.
The good news is that the DOF will be supported.
Video: Tutorial 17.Camera 360 and DOF. - YouTube
But there are some notes:

  1. the color scheme will be slightly different from the standard one;
  2. since DOF is a screen space effect, there may be seams in the blur, but if you try, you can avoid them.
    The update has already been sent to the Marketplace for verification.

Added new function:


  1. You need select Mode -> example: 360 Mono (Use 6 cameras).
  2. Custom Render -> True
  3. FullPostProcess -> True
  4. Change values for DOF.

Note: Not working in 360 Mono (Use 1 camera). DOF raytracing support, but for record you need used sequencer or movie render pipeline. I need to change the logic of creating screenshots for raytracing + custom render and dof.

I followed your “Tutorial 5. Raytracing. Camera 360 for Unreal Engine 4” applied on your Demo_Scene, I modified a bit the walls with a glossy material, but in the 360 generated image i can’t see the raytracing effects(reflections, shadows).

UE 4.25
GeForce RTX 2080Ti

Hi, ACCADarioS!
I’m going to record a new video lesson.
Waiting please.
Tutorial uploaded 5-10 min. and tutorial in Archviz Reytracing + Movie Render Pipeline for clear image

If you see any errors please let me know.

Hello, I set 30FPS Time 0~ 90 in Sequencer

The sequencer is over when the output pictures are 35
After 36 photos are repeated

How to set the correct FPS?

Sorry my English is not very good, I can only use Google Translate

camera Rec settings


You have several rendering options:

  1. Sequencer you see, 30 fps frame rate.
  2. HighResShot system . (if used Sequencer or Movie Render pipeline, dot’t forget OFF REC value)
  3. Movie Render Pipeline

Look, all modes => 30 FPS frame rate and 90 frames time.

I remind you that the first 5-10 frames activate the 360 camera.
Did the decision help you?.

Thank you!
The problem is solved!

But now I have a small problem
When I add special effects of smoke, this will appear on the screen
Is there a way to solve it?

:slight_smile: Yes, try this solution.

Some Post processing does not work, artifacts appear in the form of seams.

  • Vignette = 0 (In Post Process);
  • Bloom = 0 (In Post Process);
  • ScreenSpace Reflection = 0 (In Postprocess);
  • Atmospheric Fog - volumetric off;
  • Exponecial Heigh Fog - volumetric off;
  • Directional Light - Light Shafts Off;
  • Exposure (Sometimes due to the uneven distribution of exposure occurs in the seam. Try to adjust the check Exposure method Manual and change Exposure value).
  • Ambient Occlusion (Sometimes).
  • DOF needs to be turned off;


Thanks again for your amazing work and your help for my last post on your forum. I manage indeed to solve our problem with artefacts with the HighRes system.
We have a new problem on the image below with a very blurry render of our countryside map with the 4.23 version of unreal.

We have not this problem when we render the same map on 4.25 or when we play in editor or new window or in VR with the 4.23.

We tried :

  • All your new methods to have quick render (movie render, High Res, Sequencer)
  • Try to change parameters of each method each step
  • Erase artefact possible origins : post process, shaft, vignette etc…
  • Try to change your blueprints parameters and links in the CameraRec 360 blueprint to see if there is a link
  • Try to set excute command inside blueprints to force PostProcess, Antiliasing etc…

Do you have any clue to fix it ?
Thanks again for your help.

Best regards,

Hi,** HeaMind! **
Thank you for your feedback!
Send me an email I could connect to you remotely and check what the problem might be.
I think it’s Depth of Field you have installed in the Post Process. You need to set everything to 0

hi , i have a problem that my Camera_Rec_360 always show green.
does anyone have the solution?


Hi, YuCang!
This is how it should be. You need to press the Play button or Simulate and you will see that the 360 camera is working.
If you need the camera to work in real time in the engine, click on the Camera Point 360 actor and select "realtime in editor".