Download

CAMERA 360 System (Blueprints)

Hi, we have a stitching issue.

We’ve captured using the CAMERA 360 System with :

  • Post-process Volume and Chameleon post-process
  • No vignette
  • No bloom
  • PNG format

After capturing we’ve encoded the images using Adobe Media Encoder to H264 then we used Spatial Media Metadata Injector to play the video in 360 mode using common video players.
But we have this issue with almost all tested video players : GoPro VR Player 2.3, VLC 3.0.11 and Vimeo (Only “Movies & TV” from Windows have a different result)

360Addon-360Capture-IssueVisible.JPG

This is captured with the Unreal’s Panoramic Capture Tool and the same encoding process :

UnrealNatif-360Capture-NoIssueVisible.JPG
(But it takes 1min to capture one frame … so not suitable for production)

Good afternoon, corentin-dpt!
I am currently working on fixing this problem.
This is not related to the post-process.

As a temporary solution:
1.you can blur the lower part of the background in any video editor program;
2. Place a sphere or object with a blur material at the bottom, or darken the area.

Ok Great!
Unfortunately, blurring the problematic part of the image is not a valid solution for our project.
When can we expect a new version with this bug fixed?

Hi!
I’ll give you an answer tomorrow. I hope I can resolve this issue quickly.

Hi!
I need to run some more experiments.
But I have already sent an updated version to the market. It eliminates problem areas.
But I only did this for Right Eye Mode.
When I check everything, I will make changes to the standard Left Eye mode as well

**NEWS 07/02/2020. New update. **

  1. Please Restart Epic Games Launcher
  2. Update Camera 360
  3. Add and replace Camera 360 in your project…

Changes were made to the name of the modes. There will now be two modes available for rendering 360 images.

Modes_.jpg](filedata/fetch?id=1783494&d=1593704491)

  1. Mono 360 (Use 6 cameras) - uses 6 rendering render targets in the rig of 6 cameras. In this mode, if necessary, you can disable unnecessary cameras.
    Old name Mono (Left Eye)
  2. Mono 360 (Use 1 camera) - used 1 render target and 1 camera. Now there are no distortions at the bottom and top.

The format of the equilateral projection is slightly different for the two cameras.
Choose the one that suits you best.

Example image:
Use 1 camara.

](filedata/fetch?id=1783495&d=1593704603)
Used 6 cameras.
](filedata/fetch?id=1783496&d=1593704603)
Modes.jpg](filedata/fetch?id=1783497&d=1593705438)

If you have any errors, please let me know. The update has been sent to the store and will be available soon.

NEWS 08/02/2020. New update for 4.23, 4.24 and 4.25 version. Added Custom Render passes for HighResShot system. Experimental functional.

  1. Please Restart Epic Games Launcher
  2. Update Camera 360
  3. Add and replace Camera 360 in your project…

The new update adds experimental custom rendering passes functionality for the HighResShot system.

](filedata/fetch?id=1783985&d=1593796742)
Please see small tutorial.

Example images:

](filedata/fetch?id=1783988&d=1593797359)
](filedata/fetch?id=1783991&d=1593797359)

Notes:

  1. At the moment, I have managed to achieve these rendering passes, but they may differ from the custom rendering received by a standard camera via a sequencer. because the render target texture is used.
    ​​​​​​2. Custom rendering not working in mode: Mono 360 (Use 1 cam) , Omni Stereo, Stereo Panoramic mode.
  2. Raytracing + custom rendering in this update not support, i think add support in next update.
    Please don’t false FinalImage for Raytracing, or not rendering.

Hot Key for HighResShot = M.

Therefore, this functionality is experimental.
If you find any errors, please let me know.

Hello,

I’m running into a tricky artifact when using Camera 360 plugin. I have tried all the methods that I deemed interesting in the forum but with no luck:

  • Disabling the post-process
  • Disabling the fog and reflections
  • Capturing in all 360 model planes
  • Activating “use separate process and close the editor when capturing”
  • Using manual mode capture You can find attached a picture showcasing the problem.

You can find below a picture of the artifact.

Does anyone know how to resolve the problem please?

Thanks a lot for your help !

Good afternoon, Scripted!
Thank you for purchasing the 360 camera.
This artifact occurs when there is a lack of video memory. What computer do You have?

To avoid such artifacts, there are several solutions:

  1. Try used HighResShot system - https://youtu.be/J7uEiOhkH8o
  2. Try used new system in UE4.25 - Movie Render Pipeline - https://youtu.be/a_vp7b5Blyg
  3. If used Sequencer https://youtu.be/HXADxhSp0To , try used Separate Process and Closed Editor
  4. Try reducing the size of the texture.
    Quality(Experimental) - True
    Quality Size = 2500-3000 px.
    Output Size = 6000x3000px.
  5. If you use Omni Mode for Stereo. Size You need to change the texture size manually.
    Open folder Camera_360\Textures\RenderTargetStereo and open, and change 4096 px -> 2048 or 2500.
    In the next update, I will make this process automatic.

If this doesn’t help, please email me. Let’s see what else we can do.
Send me an email Lenina62-ivan@mail.ru.

Attention. With the new update, I found a delay in rendering with raytracing.
The update has been sent to the market.
I had to roll back the version. Exclude Custom Rendering until I fix the errors.

NEWS 07/06/2020. I apologize for the erroneous update. Now the errors are fixed.

  1. Please Restart Epic Games Launcher
  2. Update Camera 360
  3. Add and replace Camera 360 in your project…

Custom render passes was added as an experimental feature. This functional for HighResShot system.

](filedata/fetch?id=1784928&d=1594043759)

Note:

  1. Does not work with raytracing
  2. Doesn’t work with modes: 360 Mono (1 cam) , StereoPanorama mode, 360 Stereo (Omni)
  3. Not working in sequencer, movie render pipeline. Working for HighResShot System.

This new interface. For working Custom render, you need

  1. Chose Mode projection
  2. Custom Render - True
  3. And select render pass.
    ](filedata/fetch?id=1784930&d=1594044019)

This is an experimental function. If you see any errors, please contact me. I can always return the previous version of the 360 Camera.

I am just rendering still 360 views. I would like to be able to setup several cameras in my scene and press render to render out all the cameras I have setup. Is this possible?

Hi, Pulsestudio!
If I understand correctly. You have several cameras in the scene and would you like them to take turns rendering? Right?
This lesson shows how you can attach a camera to all cameras and start rendering via a sequencer.
https://youtu.be/BO6LiAyHyaU​​​​​​​

thanks for the sequence video, I will look at this and see if it works for us. Another issue is that when I add your camera to my scene I get strange flickering on my glossy materials.

Any thoughts on why this is happening? It starts as soon as I add the 360 point camera to the scene. Working in 4.25.1 by the way

Hi, Pulsestudio!
I hope this helps you.
I can’t figure out what’s going on from the picture :frowning:
https://forums.unrealengine.com/core/image/gif;base64
​ .
Can you show your camera settings? It looks like the post process settings are being reset.
If you use auto post-process configuration, then the all settings in post-process may be reset.
4e841419dc599b50169e754e238e72e47c2b1ede.png
Note:
-Planar Reflection - is not supported.
-Sometimes seams may be visible. Not recommended to use ScreenSpaceReflection since the all camera’s in unreal egnine used screen space.
-Recomended use Raytracing reflection.

https://forums.unrealengine.com/core/image/gif;base64

Good afternoon!
You’re right, it’s very strange. I’m thinking about a solution now. This problem is for some reason only in version 4.25, in the rest of this problem is not present.

The good news is that if you run rendering, there will be no artifacts.

The problem for some reason in Screen Space Reflection in in editor.

There are two solutions so far:

  1. Add the 360 camera to the project later;
  2. Work as is, the 360 camera is not affected by this and the artifacts will not be on the final rendering.

I think today I will find a solution to fix it or contact Epic Games for help.

I found a problem in Unreal engine 4.25.
Which causes artifacts to appear in the scene.
For smoothing, I use the command
r. PostProcessAAQuality 0-without smoothing,
r.PostProcessAAQuality 2 - smoothing.
So that’s the problem with the engine.
I will create a query in Epic Games.

Temporary solution:
If you are bothered by artifacts and don’t need smoothing:

  1. Open Actor Camera Rec 360 and open Construction script and destroy line 1.

https://af12.mail.ru/cgi-bin/readmsg?id=15942782412094021731;0;1;5

  1. If this doesn’t bother you, you can still work like this: there are no flickering artifacts in the final render.
  2. i think Using Raytraysing. This error Screen Space Reflection
When you disable the line, save the changes and restart the project. The problem will disappear

@ElizzaRF
Hello!

We just purchased your plugin, and would like to capture a movie, but with no luck so far.

We tried with an Emtpy Level, with a ground plane and background sky. Added a Camera Actor, animated it in the Sequencer, and followed the steps in the tutorial below with the Camera_Point_360 Camera_Rec_360 objects.
https://www.youtube.com/watch?v=HXAD…QwBbyOb_YGDcy1

  • When trying Sequencer “Render Movie” option, only the original camera’s view gets exported, with no panoramic projection.
  • When trying to use “Screen Shot System” “Screen Shot Rec” option in the Camera_Rec_360 object, a panoramic images get exported, but it does not match the animated camera’s route. The camera position does not change, but on the animated background sky the movement of clouds is visible. But the camera does not move, so the same frame gets exported 150 times.
  • Sometimes we can see other frames appearing in the exported images, but they have no proper order. For example first and last frame gets exported, and then the last frame gets exported 150 times.

We tried it on 2 different configs:

  • Ryzen Threadripper 1950X, 32 GB RAM, 2x Geforce GTX1080 Ti
  • Intel i7-5930K, 128GB RAM, 2x Geforce GTX 1070

What could be the problem? Is the hardware not enough for the capturing?

Is there maybe a sample scene available so we can try if the settings are messed up?

Thank you!

Hi, Narmer Visual!
Thank you for purchasing the 360 camera.

Camera 360 and Camera Cut tutorial - https://youtu.be/BO6LiAyHyaU .
Camera 360 and Master Sequencer tutorial - https://youtu.be/pHPKJRH7Uxw
You Need select your Cut and right mouse button, next step select Deactivate track https://youtu.be/BO6LiAyHyaU?t=322

-What could be the problem? Is the hardware not enough for the capturing?
No, this problem Camera Cuts. Don’t worry. Deactivate Track. Don’t delete.

-Is there maybe a sample scene available so we can try if the settings are messed up?
Demo maps in Camera_360/Maps/Demo_Scenes

Tell me, did the decision help you?