Download

CAMERA 360 System (Blueprints)

Thank you! Please keep us updated!

Hi!
Soon there will be news about 360 stereo.

**News 01/20/2020. Update sent to store. New update 1.13 Fix 6. **

Please see new stereo image.

https://drive.google.com/open?id=1Qr…Cf8RsmxUEARRCa

In the new update, the stereo modes 180 and 360 are fixed.

1. Mode 180 stereo.

  • Camera Left and Right now the eyes form a greater stereo effect.
  • Camera Top and Bottom unchanged.

2. Mode 360 stereo.

  • Fixed looks stereo for camera Front, Back, Left and Right cameras. Now the stereo effect does not break. When turning in 360, now the eyes are not inverted.
  • Camera Top and Bottom - I had to remove the stereo for these cameras. To avoid problems with stereo and cornering.

I looked through many possible solutions, while this is more or less a working option for 360 video in stereo format.

I added a little debug mode. The display of the right and left eye in debug mode, starts when a simulation or game.

  1. The red zone - if your object falls into the red zone, this is a very bad stereo for the eyes. Comfortable distance for stereo outside the red zone.
  2. You can see, when debug is activated, see in which areas there may be problematic seams for the stereo mode.

Result for stereo - RIGHT Eye:

This happens because all the cameras are shifted to display the stereo correctly, but a seam artifact appears in the right eye.
I think considering that the left eye without seams, to some extent with the help of video editors, you can gloss over the seam, but for now it’s hard for me to say for sure.

Looking up and down, I ruled out stereo so that there was no problem with inverting the image until I came up with some new working way.

Please let me know if this update helps you. If there are errors, be sure to let me know.

Hello **ElizzaRF,**many thanks for your advice. I managed to export 8k video with the HighResShotSystem. I have one more problem: it take a long time to do it. My computer need one hour to export 160 .png picture. Could you have a look to my setting please ? (see photo in attachment) I think several paramater can be optimize.

See below more setting which doesn’t appears in the picture :

  • I changed the resolution of each render target Textures to 4096 px (12 pictures). I don’t know if this setting is the same as “Quality (Texture Size)” appearing in Camera_Rec_360 properties. May one of this setting have priority to the second ? Or they don’t do the same thing maybe ?
  • I have 8GB of graphic card memory
  • My goal is to have the most accuracy aliasing. Indeed, the project I am working on is like vector picture. Line must be as clear as possible
  • below the link to the export video test

https://youtu.be/YxZZ9Z7_1HM

Have a good day

@ElizzaRF oh my, so volumetric 360 is finally fixed? Amazing! It will work with previous pre-rendeed videos used by the plugin, or those needs to recorded again?

Hi, Jemstoo!

Properties: Quality (Experimental) = Texture Size 12 textures.
This is the same property if you do it manually for 12 textures. You can always use this property, except when you need to adjust the focus for each camera, the depth, or a custom post-process, then you need to do everything manually.

I noticed that you set the texture quality to 7680 (Quality (Experimental) = 7680 ). This is a lot, so rendering takes longer.
I recommend that you just disable the anti-aliasing property, and then all the borders will be very clear.
Set the texture quality to 4096 and compare it with the 7680 you made earlier.Then try 5000 and compare with 7680. I think the boundaries will be very clear.

Please write to me, does the solution help you?

I noticed that there is a small seam at the bottom, I think in the post process you have the bloom = 0675 or vignette = 0.4 parameter.
To reduce the seam or remove it, you can set the value to 0.
bloom = 0 or vignette = 0.
https://forums.unrealengine.com/unre…93#post1660593

Hi, Jose I Rodriguez!

If you recorded a video in stereo format, you can only record the right eye and replace it in your video=) the changes touched the right eye for stereo.

However, it’s not 100% pure high-quality stereo yet, as you can see the seams in your right eye. Additional video processing may be required to erase the seams, if possible.

I would also recommend using debag, for example, to track areas where there may be seams, and, for example, to prevent objects from falling into them.

In any case, I will still think about how to fix the seams, but this option is really better and gives the right solution even for some seams.

You can see an example here (debug seams).


Result:

These are stitches in the right eye. As you can see, if the object falls into the suture area, there will be artifacts in the right eye.
I noticed that the farther away the objects are, the less visible these seams are. But this solution works and the 3D is displayed correctly, but with seams.

Now I will work on removing stitches, I have ideas on how to fix this, but you need to wait.

**News 01/21/2020. Update released. New update 1.13 Fix 6. **
https://forums.unrealengine.com/unreal-engine/marketplace/1595263-camera-360-system-blueprints?p=1710901#post1710901​​​​​​​

Please Exit Epic Launcher and restart. Chose Camera 360 in library products and update button.

Hello, I did not understand your explanation about Quality(Experimental)= Texture Size 12 textures, and its link with all Render Target Texture. However, I downloaded your latest version and I used it to do some test so, the 12 render target texture have 2048 px texture size by default and I didn’t change their settings this time.
In the image attached to this message, you can see 4 settings and their result. I need the best quality so, the fourth is better than the other (May I didn’t explained you correctly: I need anti-aliasing)
I also checked bloom and vignette. You was right and I disabled this two settings
Have a nice day

=))) Hi!

I wanted to say that this is the same =)
Previously, you had to change the texture quality manually, it was solution 1.


Please see video:

Then I released a new update new solution 2 and added a button Quality(Experimental).

Now you can just click the checkmark and change the resolution of the textures automatically.
Both methods are the same.

I see 7936 and 8192 quality experimental.
Have you checked, with activated Quality Experimental and smoothing, 4096, 5000, Is this quality still much inferior?

My Test image:

Quality Experimental = 4096 and 8000.
Antialiasing = true.

Of course you have more vector graphics and maybe the difference is more noticeable.

Try the Raytracing checkmark? And check if the rendering time changes.

In any case, I am always happy to help you. Thanks!

Hello, I found why corn and plant didn’t appears correctly. It’s not your program, it’s because I used moving material on corn and plant’s mesh. These mesh was too thin and too faster for the capture. I’m really sorry.
I replaced all mesh by flipbook texture and static texture. All is exported correctly with 4096 px render target texture. I tried more but no improvement.
Thanks a lot

Good afternoon!
I understood you. You have an amazing project. I am glad that you have found a solution. If you have any more questions, be sure to write to me.

Hello, thank you for your compliment. I manage to do this project better and faster thank to your you. Now, I have two question :

  • Firstly, I don’t need to calculate all pixel of each frame. That is to say my project will be projected on a planetarium dome so half of the picture are off frame area. Is it possible to calculate only the white part of the picture ? See picture in attachment. I think about that to minimize render time and not calculate pixel which are not necessary. By doing this, maybe we can up the size of the picture ?
  • Secondly, do you know if a 16K render will be available in the future ?
    Have a nice day

Hi ElizzaRF,
the latest changes are very useful, I really appreciate your activity.
I have a problem with the latest update: one of the two two eyes makes the floor sink!
I’m checking the image on oculus quest!

I send you the image by email…

Hi, Jemstoo!

  1. Can you send a full frame and indicate areas that you do not need? I find it difficult to navigate the image, is this a complete picture? You can note the value of Debug Border, so that I can easily navigate?
  2. The maximum image size is limited by the Unreal engine. Maximal image size for 360 in HighResShot = 16384x16384 px for 1:1 or 16384x8192 for 2:1 aspect ratio.
    If you need the maximum value of the image, do not forget to increase the Render Target Texture (Quality Texture = example 5000-8000)

Note: If you render 1: 1, you may notice the picture may be clearer (this option captures more pixels), this is another option how to improve image quality.

Good afternoon, alb3360!
I will now check the images on HTC Vive and check.
I can’t figure out what it means to sink the floor
I need to check. I’ll write to You later.

Hi, alb3360!

I checked your image, you’re right :frowning: Yes, I’m working on it now to fix it. This is because all the cameras are offset to display the stereo correctly, but the seam artifact appears in the right eye in all the cameras, and this is especially observed at the bottom.

Can you try raising the camera higher?

I hope to fix this in the next update.

Hi ElizzaRF, you will find in attachement the picture with debug border. The blue area is the one I don’t need to calculate. I took a screenshot to capture black picture with debug border so I’m not sure that is correct. Anyway, for the previous picture: the red zone is the blue one here, and its size is the final export (4096x2048)
I’m glad to know 16k export is already available. I thought UE can’t do it. However, my computer can’t do it. Probably because of my 8 GB memory graphic card

Hi, Jemstoo!

  1. I checked the rendering of 360 images.

Rendering time frame 360 = 20-30 sec.
Size output png = 16384x8192px
Render Quality = 6000 px.
Aspect ratio:2:1.
The Raytracing value must be activated. This reduces the memory load.
Size output image: 187 mb.
and please see image settings:


Image example.
https://drive.google.com/open?id=1K2…ggy4GZ4BpDydOf

My computer specifications:
Videocard: RTX 2080ti
CPU: Core i7 7700k
HDD: SSD

  1. You can turn off the camera and be able to reduce the load.
    Try the following:

  2. Open Camera Rec 360 actor;

  3. Find Render Quality

  1. Find SceneCapture 6 and change render quality 1 px.

Write to me, did the solution help you?

Perfect, almost : I can’t do rendering after 8192 px. I think it’s about my computer specifications :

Videocard: RTX 2080 Duke 8 GB
CPU: Core i7 6700 3.40 Ghz
HDD: SSD

But it’s fine, pictures are awesome already, all the bottom are one pixel rendered : )

  • rendering of 360 images :

Rendering time frame 360 = 17 sec.
Size output png = 8192x4096px
Render Quality = 6000 px.
Aspect ratio:2:1.
Raytracing value activated.
Size output image: 42 mb.

I have one more question : what is “delay next frame” ? It’s 2 in your settings but 0.5 by default