C++ Compile Failure

I have no idea why, but C++ files don’t seem to compile!
I tried reinstalling Unreal, updating XCode, updating to OS X El Capitan.

I emptied by temp folder and checked for duplicate WebBrowser and CEF3Utils folders

Can anyone please help me???

Hello stellarxo,

You mentioned that you have updated both VS (Visual Studio) and your OSX version. If you’re using OSX, you would need to use XCode to compile for UE4. Would this be the reason for your problem?

That is 100% what I meant. Sorry

What version of XCode are you using? Also, is this your first time trying to compile a C++ project? If not, did it work previously? If so, which editor version was it on?

Is this with a blank C++ project or one that is based off a template? Can you please try opening the XCode project itself and seeing if there is any additional information in the output log there?

We haven’t heard from you in a while, stellarxo. Are you still experiencing this issue? If so, could you answer the questions I asked in my previous comment? If not, please let us know what fixed it, for the sake of future users. In the meantime, I’ll be marking this as resolved for tracking purposes.

I’m using version 7.1.1

Yes, this is my first time.

I tried first with a tutorial, then with a new project using an Actor C++ class.

There is nothing in the XCode Console or in the log navigator… I’ve also never used XCode before.

Sorry, I’ve been really busy… Thanks for your help!

You mention that this happens when adding a C++ actor class. When you created the project, was it based off Blueprint or C++? If it wasn’t based off C++, can you try making one that is based of C++ to see if you receive similar errors?