Built lighting, no shadows?

I just built the lighting and in some area’s I have reall dark shadows, and then in some area’s I have no shadows at all and it makes my assets look like they’re floating, any advice? thanks.

I removed the link to your image. It was redirecting to **** sites. Please use a different hosting service or just attach the image here.

Sorry I have AdBlock, I didn’t know, I also didn’t know you could upload straight here lol .my bad.

Hi iPlay_Zombies,

I went ahead and removed the link to the **** site from your post. I will not give you an infraction this time as you were unaware due to adblock. However, in the future please post the images directly to the forum thread. Thank you

Have you already increased the lightmap resolution of the meshes?

Place a skylight into your level, then the shadows get a little bit brighter :slight_smile:

Yes, all meshes have a 128 light map, and I have a skylight too. Are there any certain settings within that skylight that I need to check?

Here Is my final level, the one criticism everyone has is the lack of shadows/lighting in the upstairs part